はじめに

K2Editorをご使用いただきありがとうございます。

K2Editorは、テキストファイルを開くための、テキストエディタです。 正規表現で指定したキーワードをフルカラーで強調表示出来るほか、 日本語文書作成に非常に便利な整形機能を搭載しています。

  • 特徴
  • 動作環境
  • 使用条件
  • カンパについて
  • サポートについて
K2Editor copyright(c) 1999,2000 K2
最初　 最後　 戻る　 進む　 目次


はじめに－特徴

特徴

このソフトウェアは、 もともとは拙作TaskPrizeに内蔵するエディットコンポーネントを作成するために開発を始めたのですが、 開発を行ううちにのめり込んでしまって、メインのエディタとして十分使える能力を持つことになりました。

「作者が使うため」というのがどうしても第一義になるので、 作者の使う目的にそって作成されています。 作者の使う目的には以下のようなものがあります。

  • メールなどの文書づくり
  • 仕事上の仕様書づくり
  • 数々の言語を使用したプログラム開発
  • 文書検索

そういうわけで、日本語を書くこと、 プログラミングをすることに特化した作りになっていると思います。

主な特徴は、以下のようなものがあります。

  • 正規表現によるキーワードカラー強調表示
  • メールやドキュメント作成に便利な、日本語整形機能
  • ファイル拡張子による設定項目の変更
  • フルカラーカスタマイズ
  • フルキーカスタマイズ
  • ツールバーカスタマイズ
  • マーキング機能（ナンバリングと通常マーク）
  • 使いやすく応用範囲の広いキーマクロ機能
  • マルチウィンドウとウィンドウ分割機能
  • 正規表現検索・置換
  • 自動文字コード認識
  • アンドゥ・リドゥ
  • クリッカブル URL、クリッカブル Mail アドレス
  • 常駐機能
  • GREP
  • DIFFサポート
K2Editor copyright(c) 1999,2000 K2


はじめに－動作環境

動作環境

Windows95/98/NT4.0/2000のそこそこ動作する環境。

制約事項

  • COMCTL32.DLLのバージョンが4.72以上でないとツールバーが使用できません
    IE4.0を入れると4.72以上に上がります。その後IE4.0をアンインストールしても、 COMCTL32.DLLはダウングレードされません。
    また、以下のページからCOMCTRL32.DLLだけのアップグレードパッケージを手に入れることもできます。
    Common Control Library Patch
  • IE4.0がないと、標準添付のヘルプが使用できません。
    HTMLHelpシステムが必要です。HTMLHelpワークショップがインストールされていると、 IE4.0がなくても標準添付のヘルプを使用できますが、一般的ではありませんね。
    HTMLHelpシステムがない場合は、 K2 Software's Page のK2Editorのページから、 HTMLファイルによるヘルプをダウンロードして使用してください。 この場合は、Webブラウザでヘルプが開かれます。

動作確認は以下の環境で行いました

  • 自作 K6-II 300MHz + SDRAM 64M

    • Windows2000β3
    （デュアルブート）
  • DELL OptiPlex PentiumII 266MHz + 128M

    • Windows95(OSR2)

  • テスターさんによるテスト

    • Windows98/95/NT4.0（10台程度）
    （開発協力者のみなさま、ご協力ありがとうございました）


はじめに－使用条件

使用条件

このソフトウェアは、フリーウェアです。 著作権はＫ２が持ちますが、使用は自由に行っていただいてかまいません。 ただし、使用することでデータの消失等の損害が生じても、 Ｋ２はあずかり知りません。使用者の責任で使用してください。

フリーウェアは、「ただ」ではありません。 ソフトウェアを作成するには、多大な努力と時間と投資を必要としています。 あなたがこのソフトウェアを使用する場合、なんらかの対価を提供すること希望します。 それは、ネットワーク文化に対する貢献でもよいし、このソフトウェアを使って、 一般社会に貢献するような活動をしてくださっても結構です。 もし、そういう形の貢献ができないなと思う方は、カンパの形を用意していますので、 作者に対して直接対価を支払っていただいても結構です。
もし、このソフトウェアを気に入っていただけて、 今後の作者の開発を応援してくださる場合は、 カンパをしていただけると非常に助かります。 詳しくはカンパについてを参照してください。


はじめに－カンパについて

カンパについて

このソフトウェアを使っていただいて、 もし今後の開発のために寄付をしてやろうと思われる方は、 カンパをしていだけるとありがたく思います。

カンパは、一口500円です。 このソフトウェアについての価値がどのくらいかをあなたが判断して、 何口するかを決めて下さい。

送金していただいたら、下の送信フォームに従って、メールをお送りください。

  • Vectorのシェアレジを利用する場合

    以下のurlにアクセスしてください。
    https://sw.vector.co.jp/swreg/step1.reserve?srno=SR015117
    このページから、送金できます。 カード決済になるので、クレジットカードをお持ちの方なら、誰でも送金できます。 ただし、VECTORでは一律100円の手数料が取られるので、一口を1000円にしてあります。 500円単位で送金する場合は、銀行振り込みを利用してください。

    なお、VECTORでは、 同一ソフトに送金するのは24時間に１度だけの制限がついています。 もし複数口送金してやろうという方は、24時間以上待って、 送金してください。ご迷惑おかけします。

  • NIFTY送金代行サービスを使用する場合

    NIFTY SERVEの送金代行サービスも使用できます。 送金代行番号は、10718です。こちらも一口1000円で設定してあります。 500円単位で送金する場合は、銀行振り込みを利用してください。

    GO SWREGで送金代行サービスにいけます。 送金代行サービスに入ったら、 「3:シェアウェア番号指定」「2.送金システム」を選んで、 「1:シェアウェア番号指定」で、代行番号「10718」を入力して送金してください。

    送金代行サービスをご利用できるのは、 カード決済の方のみです。また領収書は発行できませんので、 カード会社の引き落とし明細書をご利用ください。

  • 銀行振り込みによる方法

    銀行振込の場合は、以下のところに振り込んでください。

    東京三菱銀行　西院(SAIIN)支店　普通口座　0224836
    小薮　一弥（KOYABU KAZUYA）

      振り込み依頼人欄には、名前を書いていただくようお願いします。 また送金した項を、メールで以下のアドレスまでお送りください。
    NAA00127@nifty.ne.jp

送金通知フォーム

どの送金方法を使用しても、メールでその項を通知していただけると、 助かります。銀行振り込みの方は必ず通知をお願いします。

-------------------------------------------
To:NAA00127@nifty.ne.jp
Subject:K2Editor送金通知

氏名：
氏名（ローマ字）：
E-Mailアドレス  ：（必ずお書きください）
送金方法：

ソフト入手場所：
知った場所：
感想、ご意見：

-------------------------------------------


はじめに－サポートについて

サポートについて

サポートは、 K2 Software's Pageで行います。 メーリングリスト・サポート掲示板がありますので、ページの説明を読んで、 参加してください。


インストールとアンインストール

インストールとアンインストールの方法について説明します。

K2Editorはレジストリを使用しないので、どちらも非常に簡単です。

  • インストール
  • アンインストール
  • フォルダ構成


インストールとアンインストール－インストール

インストール

K2Editorのアーカイブを解凍したら、どこかのフォルダにすべてを入れてください。 その状態でK2Editor.exeを起動すれば、インストールは完了です。 デスクトップにショートカットを置いたり、 スタートメニューに登録するのは、手動でお願いします。


インストールとアンインストール－アンインストール

アンインストール

アンインストールするには、K2Editorがインストールされているフォルダを、 削除してください。レジストリや他のファイルは使用しないので、 そのフォルダを削除すればすべての情報は消去されます。


インストールとアンインストール－フォルダ構成

フォルダ構成

K2Editorのインストールしたフォルダは、以下のような構造になります。

[K2Editorフォルダ]
      +---[MACRO]
      +---[DEFULT]
      +---[USER NAME1]
      +---[USER NAME2]
      +---[USER NEME3]

K2Editorフォルダには、K2Editorの実行ファイルや、ヘルプなど、 すべてのユーザー共通について共通なファイルが入れられます。

K2Editorフォルダの下には、いくつかのフォルダができます。

  • MACRO

    マクロファイル（*.mac）が入れられます。

  • DEFAULT

    Windowsにログオンせずに使用するユーザー用の、各種環境ファイルが格納されます。

  • USER NAMEフォルダ

    Windowsにログオンして入ったユーザー用の、各種環境ファイルが格納されます。

DEFAULTフォルダを含むユーザーフォルダの中のファイル名などは、 すべて共通です。もし、違うユーザーネームでログオンした場合にも、 同じK2Editor設定を使用したい場合は、 作成されたユーザーフォルダの下のファイルをコピーしてください。

バックアップをとる場合も、K2Editorフォルダごと保存すれば、 同じ環境を再現できます。ただし、Windowsユーザー名を変更した場合は、 別のユーザーフォルダが作成されるので、適宜環境ファイルはコピーして使用してください。


起動方法

K2Editorの起動方法と、起動オプションについて説明します。

  • 起動方法
  • 関連づけ
  • 起動オプション


起動方法－起動方法

起動方法

K2Editorを起動するには、以下の方法があります。

  • ダブルクリック

    K2Editor.exeやそのショートカットをダブルクリックしてください。

  • DOSコマンドラインから

    また、 DOSプロンプトからフルパスでK2Editor.exeを入力してENTERキーを押しても起動できます。 K2Editorフォルダにパスを通しておけば、k2editorと入力するだけで起動できます。

  • ショートカットにドロップ

    デスクトップに置いたショートカットなどにドロップしても開けます

  • 起動しているK2Editorにドロップ

    起動しているK2Editorの上にファイルをドロップしても、 新しいK2Editorが起動します。 ドロップされたK2Editor内の文書が「無題」で、変更されていなければ、 そのエディタでドロップされたファイルを開きます。

  • K2Editorから開くか新規作成する

    K2Editorから、新しいK2Editorを起動することもできます。 開く場合、もしK2Editorが単独起動で内容が変更されていない場合は、 そのエディタで開きます。それ以外の場合は、新しいK2Editorを起動して開きます。 新規作成の場合は、新しいK2Editorを起動します。


起動方法－関連づけ

関連づけ

K2Editorで関連づけを設定するには、 ファイルタイプ別設定の関連づけのページで 行うことができます。

もし自分で行う場合は、以下の点に気を付けてください。

エクスプローラの表示－オプション （ツール－フォルダオプションの場合もある）を選択し、 ファイルタイプで関連づけたいファイルタイプを探し、 開くためのファイルをK2Editorにしてください。

このとき、必ず以下のように設定してください。

...\K2Editor.exe "%1"

"%1"を忘れると、空白のあるパス名などのファイルを開くことができません。


起動方法－起動オプション

起動オプション

K2Editorの起動オプションは、以下のような形式です。

K2Editor.exe [ファイル名1] [ファイル名2] /option ...

オプションとファイル名の順番は、特にどうでもよいです。 オプションには以下のものがあります。オプションの添え字の大文字小文字は問いません。

  • /a

    常駐する

  • /b

    観覧モードで開く

  • /c

    指定した拡張子のファイルタイプで開く（/c.txt という風に指定する。ピリオドが必要）

  • /e

    ESC キーを強制的に終了コマンドに割り当てる。観覧モードと併用すると便利。

  • /f

    ファイル履歴に追加しない。ファイルタイプ設定より優先される

  • /g

    GREP のダイアログを開く（他のオプションと併用しないでください）

  • /jXX

    XX に数字を指定すると、ファイルを開いた後に、その行数にジャンプします。

  • /je

    ファイルを開いた後、ファイルの末尾にジャンプする

  • /l

    起動時に実行する１行マクロを指定する。
    例）"/lInputDateTime(%YYYY%年%MM%月%DD%日)"

  • /m

    起動時にマクロを実行する。/mmacro.macという風に指定する。 マクロは指定されたファイルを開いた後に実行される。

  • /n

    ファイルを実際には存在しないファイルとして開く。 （内部でテンポラリファイルを開くのに使用する）。 /f オプションを併用しないとそのファイルは履歴に追加されてしまうので注意

  • /o

    ファイルを文字コードを指定して読み込む。 /osでSJIS、/ojでJIS、/oeでEUC、/ouでUNICODEを指定する。 ファイルオプションをつけずに、 このオプションだけつけた場合は、起動してから最初に開くファイルは、 指定した文字コードになる。

  • /p

    カレントディレクトリを指定する（"/pc:\program files"など）

  • /s

    ステイタスバーの表示・非表示。/s- で非表示、/s で表示。設定は保存されない。

  • /t

    ツールバーの表示・非表示。/t- で非表示、/t で表示。設定は保存されない。

  • /z

    最大化または最小化して起動する。/z-で最小化起動する。


設定

K2Editorの設定について説明します。K2Editorの設定は、 共通設定とファイルタイプ別の設定に分かれます。

  • 共通設定
  • ファイルタイプ別の設定


共通設定

K2Editor全般の設定を行います。これとは別に、 ファイルタイプ別の設定がありますが、 こちらは開くファイルの拡張子別に設定できます。

K2Editorの共通設定は、以下のページに分かれます。

  • 一般設定のページ
  • 行の折り返しのページ
  • マクロのページ
  • キーのページ
  • ツールバーのページ
  • 整形のページ
  • その他のページ


共通設定－一般設定のページ

一般設定のページ

  • 常駐する

    K2Editorを起動すると、タスクトレイにアイコンが現れます。 詳しくは「常駐」の項目を見てください。 常駐時のファイル履歴の数は、 タスクトレイアイコンを右クリックして出るメニューに表示されるファイル履歴の数を設定します。

  • アンドゥのバッファサイズ

    アンドゥの最大回数を指定します。デフォルトは200です。

  • 起動時に最大化する

    K2Editorを起動したとき、毎回最大化します。ノートパソコンなどで、 画面が小さいときに便利な機能です。

  • 終了時に、マルチウィンドウを開いている場合、問い合わせする

    別の編集ウィンドウ（マルチウィンドウ）を開いている場合、 終了すると複数のウィンドウが閉じます。ここにチェックが入っていると、 その前に閉じてよいかどうか問い合わせます。

  • ファイル履歴の数

    ファイルメニューの中に表示されるファイルの履歴の個数を指定します。 内部的には30個の履歴を持っていますので、最大30個の履歴を表示できます。

  • カーソル位置をファイル履歴に保存

    ファイル履歴にカーソル位置を埋め込み、次に開いたときに、 そのカーソル位置にジャンプします。

  • マークのファイル履歴への保存

    ファイルの履歴の中にマーキング位置を保存します。

  • 行末・行頭カーソル移動を禁止する

    行頭にカーソルがあるときに左にカーソルを移動したとき、 前の行末に移動することを禁止します。また、行末にカーソルがあるとき、 右にカーソルを移動したとき、次の行頭にカーソルが移動することを禁止します。

  • 縦スクロールバーを使ってもカーソル位置はそのまま

    スクロールバーをマウスでドラッグしたとき、ここにチェックが入っていると、 カーソルがテキストにくっついて移動します。 画面の外に出てしまう場合もあります。

  • マウスホイールでスクロールする行数

    マウスホイール１クリック分で、何行スクロールするかを設定します。

  • カーソル形状

    カーソル（キャレット）の形状を変更します。Windows風は、縦棒のキャレットです。 Brief風は、下線状です。DOS風は、下半分のボックスタイプです。 上書き状態の時は、どのカーソルでも、すべてボックスタイプになります。

  • 検索文字を色分けする

    検索を行ったあと、検索でマッチしたすべての文字列に指定された色をつけます。 色は、ファイルタイプごとの設定の 色のページで行います。

  • コピーした後選択範囲をクリアする

    選択しクリップボードにコピーした後、選択範囲をクリアします。

  • 引用付きコピーに使用する引用符

    「引用付きコピー」「引用付き貼り付け」コマンドに使用する引用符を設定します。 スペースも含めて指定してください。


共通設定－行の折り返しのページ

行の折り返しのページ

行の折り返し設定は、文字列を設定桁数で折り返して表示する機能です。 機能のオン・オフ自体は、ファイルタイプ別設定で行います。

  • 禁則処理の方法

    ぶら下げ処理と追い出し処理があります。ぶら下げ処理は、 行頭禁則文字の句読点などを、一行桁数を超えて行末にぶら下げる処理です。 追い出し処理は、行末禁則文字を、次の行の行頭に回り込ませる処理です。

  • 改行文字のぶら下げ

    改行文字前までの文字数がちょうど一行桁数の場合、 次の行の行頭に改行コードが折り返されると、その行は空白行のように見えます。 この改行コードを行末にぶら下げる処理です。

  • 英文ワードラップ

    英文の単語を、途中でちぎれないようにする処理です。

  • 行末禁則文字

    行末にくるとみっともなくなる文字列です。この文字列は整形処理にも使用されます。

  • 行頭禁則処理

    行頭にくるとみっともなくなる句読点などの文字列です。 この文字列は整形処理にも使用されます。


共通設定－マクロのページ

マクロのページ

マクロのページでは、マクロの登録と、 マクロ文字列の設定ができます。

マクロのページでは、マクロを10個登録できます。これを好きなキーに割り付けて、 ワンタッチでキーマクロを再生できます。 マクロを設定するには、設定したいマクロ番号を選択し、 マクロの割り付けボタンを押してください。 macroフォルダに入っているマクロファイル（*.mac）が一覧になって表示されます。 このうち、設定したいマクロを選択して、OKボタンを押してください。

あるマクロ番号のマクロをクリアしたい場合は、そのマクロ番号を選択し、 クリアボタンを押してください。

マクロ設定は、ユーザーフォルダの下の、 Common.iniのMacrosというセクションに保存されます。 この設定は、K2Editorの起動時に読み込まれ、 共通設定でOKを押したときに保存されます。

マクロ文字列の登録では、マクロコマンドをマクロファイルに記述するとき、 引数の中で、ここで設定した文字列を使用することができます。 詳しくは、 マクロ用文字列記述基準を参照してください。


共通設定－キーのページ

キーのページ

キーのページでは、K2Editorのほとんどすべての機能を、 任意のキーに割り当てることができます。

  • キーの割り当て方

    まず、割り当てたいキーを、 左のウィンドウとSHIFT、CTRL、ALTの組み合わせで選択してください。 次に、割り当てたい機能を右のウィンドウで選択し、 割り付けボタンのを押してください。 割り付けられているキーに、割り付けたキーが表示されます。

    割り付けボタンを押さないと割り付けられません。
    一つの機能に複数のキーを割り当てることができますが、 ALTキーを併用するキーなどを使う場合、機能しない場合があります。 その場合は、キーを一つだけにしてみてください。
  • キーのクリアの方法

    あるキーに割り当てられている機能をクリアするには、次のようにしてください。 まず、左のキー一覧から、クリアしたいキーを選択してください。 その後、クリアボタンを押してください。 そのキーに割り付けられている機能はクリアされます。

  • キー一覧の書き出し

    どのキーがどの機能に割り付けられているか、 またどの機能がどのキーに割り付けられているかを、 テキストファイルで確認することができます。 キー一覧の書き出しボタンを押し、 セーブしたいファイル名を入力してください。

キー設定は、ユーザーフォルダの下の、 Key.datというファイルに保存されます。 このファイルは、K2Editorの起動時に読み込まれ、 共通設定でOKを押したときに保存されます。


共通設定－ツールバーのページ

ツールバーのページ

ツールバーのページでは、ツールバーのカスタマイズができます。 ツールバーのページを開くと、左に現在のボタン設定、 右に割り付けられる機能一覧が表示されます。

新しい機能を追加するには、 左の機能一覧から割り付けたい機能を選択して、 「←」ボタンを押してください。そのとき、 もしボタン一覧で選択されているボタンがある場合は、 そのボタンの上に、選択されているボタンがなければ、一番下に追加されます。

ボタンを削除する場合は、削除したいボタンを選択し、 「削除」ボタンを押してください。

セパレータを入力したい場合は、 「---」ボタンを押してください。 もしボタン一覧で選択されているボタンがある場合は、 そのボタンの上に、選択されているボタンがなければ、一番下に追加されます。

ボタンの順序を入れ替えたい場合は、 ボタンを選択してから「↑」か「↓」ボタンを押してください。 ボタンの順序が入れ替わります。

ボタンは、ユーザーフォルダの下の、 ToolBar.datというファイルに保存されます。 このファイルは、K2Editorの起動時に読み込まれ、 共通設定でOKを押したときに保存されます。


共通設定－整形のページ

整形のページ

整形機能のための共通設定を行います。

  • コメント整形

    コメント整形は、設定された行頭のコメント文字を保ったまま、 整形を行う機能です。コメント整形を行う場合は、 コメント整形にチェックを入れてください。

  • コメント文字の編集

    コメント文字を、正規表現を利用して設定します。 新規作成で、新しいコメント検索パターンを作成します。 先頭の空白やタブ文字は削除された後に検索文字を判定するので、 先頭のスペースなどにマッチさせる必要はありません。 ただし、行頭パターンである「^」は使用した方がよいでしょう。 正規表現についての詳細は、「正規表現」を参照してください。 一度設定したコメント文字検索パターンは、プロパティボタンで編集できます。 削除ボタンを押せば、削除できます。

  • 箇条書きの一覧

    箇条書き文字を、正規表現を利用して設定します。 新規作成などのボタンは、「コメント文字の編集」と同じですので、参照してください。

  • スペース補完

    これにチェックを入れると、半角文字で表された単語の両端に半角空白を補完し、 見やすくします。 右側（左側）にスペースを追加しない文字列に設定した文字列には、 半角空白は補いません。

  • 英文ワードラップ

    半角文字で綴られた単語が、改行文字で分割されないように整形します。

  • タブをスペースに変換

    整形時に、タブ文字をスペースに変換します。


共通設定－その他のページ

その他のページ

  • NIFTY URLジャンプを使用する

    パソコン通信のNIFTY SERVEで使用される、 主にログに対するポインタをNIFTY URLと言います。これを認識し、 そのログへジャンプする機能をK2Editorは持っています。ただし、 この機能を使うには、WithNIFTYか、 その他のNIFTY URLジャンプをサポートしているNIFTY用ソフトが必要です。 細かい説明は、ここでは省きます。


ファイルタイプ別の設定

ファイルタイプ別の設定を行います。

ファイルタイプを登録し、ある拡張子のファイルを読み込んだときに、 そのファイルタイプを設定すると、ファイルタイプ設定と拡張子が関連付きます。 次にその拡張子を開いたときは、そのファイルタイプが選択されます。

ファイルタイプ別の設定とは別に、 共通設定があります。ここでは、 すべてのファイルタイプに共通する設定を行います。

ファイルタイプ別の設定は、以下のページに分かれます。

  • 表示のページ
  • 入力・移動のページ
  • ファイルのページ
  • 色のページ
  • キーワードのページ
  • 文字列とコメントのページ
  • 関連づけのページ

関連項目

  • ファイルタイプ
  • タイプリストの編集


ファイルタイプ別の設定－ファイルタイプ

ファイルタイプ

ファイルタイプは、K2Editorで複数のセッティングを持つためのものです。

ファイルタイプの使用方法は、以下のような手順になります。

  • 新しいファイルタイプを作成する。必要なら設定を行う
  • ファイルタイプを関連づけたい拡張子を持つファイルを、K2Editorに読み込む
  • ファイルタイプ別の設定で、そのファイルタイプを選択し、OKボタンを押す

この手順で、新しいファイルタイプが作成され、 その拡張子とファイルタイプが関連づけられます。ファイルタイプを作成する方法などは、 ファイルタイプの編集を見てください。 次から、この拡張子を持つファイルを読み込む時には、そのファイルタイプが使用されます。

一つのファイルタイプを複数の拡張子の種類に割り当てられますから、 たとえば「.html」と「.htm」に、 「HTML」というタイプ名を持つファイルタイプを割り当てられます。

K2Editorをはじめて起動したときには、「共通」というファイルタイプが用意されています。 このファイルタイプは特別で、削除することはできません。 特に関連づけられていない拡張子を持つファイルをK2Editorに読み込んだ場合、 この「共通」のファイルタイプが使用されます。


ファイルタイプ別の設定－ファイルタイプの編集

ファイルタイプの編集

ファイルタイプごとの設定ダイアログの右上にある、 タイプリストの編集ボタンを押すと、このダイアログが現れます。

新しいファイルタイプを追加したり、 削除したりするのは、このダイアログで行います。

タイプリストは、現在設定されているファイルタイプの一覧が表示されます。

  • コピー

    現在あるファイルタイプの設定項目をすべてコピーした、 新しいファイルタイプを作成します。たとえば、 「共通」ファイルタイプに設定した色設定やキーワードなどを引き継ぎたい場合、 「共通」ファイルタイプを選択してからこのボタンを押して、 新しいファイルタイプを作成してください。 このボタンを押すと、名前を入力するダイアログが出ますから、 ここに新しいファイルタイプの名前を入力してください。

  • 新規作成

    新しいファイルタイプを作成します。コピーとは違って、 K2Editorが持っているデフォルトの設定を使用して作成します。 名前を入力して、新しいファイルタイプを作成してください。

  • 削除

    選択されたファイルタイプを削除します。関連づけられた拡張子は、 共通ファイルタイプを使用するように変更されます。

  • 名前の変更

    選択されたファイルタイプの名前を変更します。


ファイルタイプ別の設定－表示のページ

表示のページ

このページでは、表示関連の設定を行います。

  • フォントの種類とサイズ

    フォントの種類とサイズを設定します。ボタンを押すと設定ダイアログが出るので、 フォントとサイズを選択してください。

  • 起動時ウィンドウ

    標準では、起動時の位置とサイズをOSに任せます。 サイズを固定する場合は、 設定された幅と高さから大きさを計算して表示します。 位置を固定するにチェックを入れると、 位置の記憶ボタンを押したときのK2Editorがあった位置を覚えておき、 そこに表示します。

  • タブの文字数

    タブの文字数を設定します。

  • 行間と文字間

    行間と文字間のピクセル数を設定します。 カーソル行アンダーラインを表示する場合は、行間は１ポイント大きくなります。

  • 長い行の折り返し

    設定された桁数で行の折り返しを行います。折り返しに関する他の設定は、 共通設定－一般設定のページを見てください。

  • カーソル行アンダーライン

    カーソル行の下にアンダーラインを引いて、 カーソルがどこにあるかをわかりやすくします。 アンダーラインの色を設定すると、色の変更ができます。

    カーソル行アンダーラインを表示すると、自動的に行間に１ポイントの空隙を挿入します。
  • スクロールバー

    縦スクロールバーと、 横スクロールバーを表示するかどうか、指定します。

  • ルーラー

    垂直ルーラー（行番号表示）と水平ルーラ（桁数表示） を表示するかどうかの設定を行います。 左マージンに縦線を描くにチェックを入れると、 垂直ルーラがなくても、左余白と編集領域の間に縦線を描きます。 論理行番号は、長い行の折り返しをおこなっているとき、 折り返された行にも行番号をつけます。

    マーキング機能に使用するマーカーを左余白に表示するため、 左余白が少々大きめに取ってあります。
  • 特殊文字の表示・非表示

    全角空白などの特殊文字を表示したり彩色を施したりするかどうかを設定します。 特にどういう色で表示するか、下線を引くかなどは、 色のページで設定します。 URL・E-Mail・File・NIFTY URLについては、 チェックをすると、それらの文字列をマウスでダブルクリックすることで、 それに見合った動作が起きます。URLの場合はブラウザが起動し、 E-Mailの場合はメーラーが起動します。Fileでは、そのファイルを実行します。


ファイルタイプ別の設定－入力と移動のページ

入力と移動のページ

このページでは、入力と移動に関するオプションを設定します。

  • フリーカーソルモード

    フリーカーソルモードにすると、カーソルを改行よりも右に置くことができます。

  • オートインデント

    オートインデントにしておくと、行頭をスペースやタブをいくつか置いて始めているとき、 行末で改行を入れると、次の行頭に自動的に、 前の行のスペースやタブを挿入します。 全角スペースでもインデントするにチェックを入れると、 全角スペースもインデントの対象にします。 すべてスペースに置き換えるにチェックを入れると、 インデント挿入時にタブや全角スペースを半角スペースに置き換えます。

  • 日本語IMEをオンにする

    K2Editorにフォーカスが移ったときに、日本語IMEをオンにします。

  • インデントは半角スペースで行う

    インデント挿入時に、半角スペースをインデント幅分、挿入します。 チェックが入っていなければ、タブ１個を使います。

  • インデント幅はタブ幅と同じ

    「インデントは半角スペースで行う」場合、スペースの数を、 設定されているタブ幅にそろえます。チェックをはずすと、 タブ幅とは別に、独立にインデント幅を設定できます。

  • 整形関連
    • 整形文字数

      整形を行ったときの１行文字数を設定します。

    • 句読点によって整形を行う（自動整形）

      設定された句読点が入力されたときに、自動的に整形を行います。 これを自動整形と呼びます。

    • 整形のトリガー

      自動整形を行うときの、トリガーとなる句読点などを設定します。

    • 自動整形桁に縦線を入れる

      自動整形時に、整形される桁付近に縦線を入れることができます。 変更ボタンで線の色を設定してください。

    • コメント整形のみ行う

      この場合、先頭がコメント文字の行の場合だけ、整形を行います。 たとえば、CやPascalのソース編集を行っているときに、 先頭が//の行だけ、整形を行いたい場合などにオンにします。


ファイルタイプ別の設定－ファイルのページ

ファイルのページ

保存関連の設定を行います。

  • 保存するときにタブをスペースに展開する

    保存時に、タブをスペースに展開してから保存します。

  • 保存時に行末の空白やタブを削除する

    保存時に、一般的に不要な行末の空白やタブを削除します。 全角空白も削除するにチェックを入れると、 半角空白・タブと併せて、全角空白も削除します。

  • バックアップファイルの作成

    これをオンにすると、セーブ時にバックアップファイルを作成します。 バックアップファイルは、 開いているファイルの拡張子を「.bak」に変更したものになります。

  • 保存時にアンドゥバッファをクリアする

    上書き保存などをした場合に、それまでのアンドゥ情報をクリアします。

  • ファイル履歴には追加しない

    ファイルを開いても、そのファイルタイプで関連づけられた拡張子のファイルは、 ファイル履歴に追加されなくなります。テンポラリファイルなどを指定してください。

  • セーブした直後は上書き保存ができないようにする

    セーブした後、変更するまで、上書き保存を使えなくします。

  • 外部マクロの別パス

    ここにマクロフォルダ以外のパスを指定すると、 そのフォルダのマクロを起動することができるようになります。 パスは一つだけ指定できます。 また、ここに指定したパスのマクロは、 共通設定で番号付きマクロに割り当てることはできません。
    使わないときは空欄にしておいてください。


ファイルタイプ別の設定－色のページ

色のページ

色の設定を行います。

左に色の設定をする文字種類が表示されます。設定したい文字種類を選択して、 右のパネルで設定します。 わかりにくい文字種別を説明します。

  • 普通の文字

    すべてのベースになる文字種ですが、実際に表示に使われる部分はほとんどありません。 ここで設定した背景色を、 他の文字種に背景色の統一ボタンでコピーできます。

  • 改行文字・タブ文字・全角空白・EOF

    表示のページで各文字を表示する設定にしたときに、 ここで設定した色で各文字を表示します。

  • 文字列

    文字列とコメントのページで設定した囲い文字で囲まれた文字が、ここでいう文字列です。

  • 行番号

    左マージン内の色と行番号の色を指定します。

  • 強調表示と行の強調 キーワードのページで指定したキーワードの表示形態を設定します。

各種ボタンの意味を説明します。

  • 背景色の統一

    選択範囲をのぞいたすべての文字種の背景色を、普通の文字に統一します。

  • すべてリセット

    すべての文字種の色設定を、デフォルト値に変更します。

  • 文字色と背景色

    選択されている文字種の文字色と背景色を設定します。 透過にチェックを入れると、 文字以外は下の色をそのまま表示します。

  • ボールドなど

    選択されている文字種のフォントスタイルを指定します。斜体や取消線は、 きれいに表示されない場合があります。

  • リセット

    選択されている文字種の色設定を、デフォルト値に戻します。

  • 色設定の保存と読み込み

    現在の色設定をファイルに保存し、また保存した色設定を読み込むことができます。


ファイルタイプ別の設定－キーワードのページ

キーワードのページ

このページでは、強調表示させるためのキーワード設定を行います。

キーワードの強調表示のチェックボックスにチェックしないと、 このページの設定は有効になりません。キーワード強調表示を行うためには、 このチェックボックスをオンにしてください。

その下に、キーワード設定の一覧が表示されます。 この一覧に設定されたキーワードは、下から順に強調表示が行われていきます。 上に行くほど上書きをするので、上の方の設定がより有効になります。

カラムをクリックすることでソートできますが、 これはキーワードの重複などをチェックするためのもので、 どのカラムをクリックしてもキーワードでソートされます。 また、ソートした優先順位は保存されません。

  • 追加のボタン

    新たなキーワードの追加を行います。ボタンを押すと、 キーワードのプロパティが開きます。 ここで必要な設定をしてOKボタンを押すと、新たなキーワードが追加されます。

  • プロパティボタン

    選択したキーワードの設定を編集します。キーワード一覧で、 編集したいキーワードを選択しこのボタンを押すと、 キーワードのプロパティが開きます。

  • 再描画のボタン

    リストのカラムをクリックしてソートした場合、 そのままでは優先順位の変更ができなくなります。 このボタンを押して、元の順に並べ替えてください。

  • ↑・↓・先頭へ・最下位へボタン

    キーワード一覧は、上の位置にあるものほど優先順位が高いので、 これらボタンを使って、優先順位を変更してください。

  • 削除ボタン

    選択されたキーワードを削除します。

  • 全削除

    設定されているすべてのキーワードを削除します。

  • 保存・読み込みボタン

    設定されているキーワードを外部ファイルに保存したり、 外部ファイルからキーワードを読み込んだりします。読み込む場合は、 現在の設定の下に追加されます。 この設定には、 文字列とコメントのページの設定も含まれます。 外部ファイルのデフォルトの拡張子は(*.hil)です。 秀丸のハイライトファイル（*.hilight）を読み込むこともできるようです。

    hilファイルは、テキストファイルで、以下のような構成になっています。
    -----------------
    識別子,キーワード
    識別子,キーワード
    識別子,キーワード
    -----------------
    識別子は、以下のような数字の和です。

      1: とりあえず足す
  2: 未使用
  4: 行強調
  8: 大文字小文字の区別をしない
 16: 正規表現
 32: ワード
 64: 強調1Bit
128: 強調2Bit
256: 強調3Bit
512: コメント

    強調の３ビットは、0から7までの数字を表します。 0は000、1は001、2は010で、それらの数字を足します。 つまり、0は0、1は64、2は128、3は196という風になります。 これらの属性をすべて足して、識別子を出します。

    41,BEGIN

    これは、単語検索で、大文字と小文字を区別しない検索条件で、 「BEGIN」という語句にマッチするキーワードとなります。


キーワードのプロパティ

キーワードやコメント文字、箇条書き文字の検索条件を設定するときに、 このダイアログは現れます。

  • キーワード

    検索条件になる文字列を設定します。キーワードには正規表現も使えます。 正規表現を使う場合は、 検索方法の正規表現のチェックボックスにチェックを入れてください。

  • 検索方法

    検索の時の条件を設定します。

    • 大文字小文字の区別

      チェックを入れると、大文字と小文字を区別します。

    • 単語の検索

      チェックを入れると、単語としてキーワードがマッチする場合だけマッチします。

    • 正規表現

      正規表現を使用してキーワードを設定します。

    • あいまい検索

      正規表現時に、あいまい検索を使用します。

  • 表示方法

    キーワードのプロパティの場合、表示方法に、 そのキーワードを強調表示する場合に使用する文字種が表示されます。 好きな文字種を選択してください。

正規表現に関しては、JRE32.DLLの説明書(README.JRE)や、 市販の参考書を参考にしてください。


ファイルタイプごとの設定－文字列とコメントのページ

文字列とコメントのページ

コメント系の表示を行わせるための設定をします。

  • 文字列だと認識するための囲い文字とキャンセラー

    プログラムソースなどで、文字列だと認識させるための囲い文字を、片側だけ設定します。 たとえば、Cソースの場合は、「"」を設定してください。 Pascalソースの場合は、「'」です。これを設定しないと、 コメントセット文字列が文字列の中に現れた場合、コメントセット文字列を誤認します。 キャンセラーは、「文字列だと認識するための囲い文字」 そのものを文字列として認識させたいときに、その文字の前に置く文字を意味します。 たとえば、Cソースの場合は、「\」を指定します。 Pascalソースの場合は「'」を指定します。 ３組まで登録することができます。

  • これ以降をコメントとする文字列

    プログラムソースなどで、特定の文字列以降、改行までをコメントとするような、 特定の文字列を設定します。C++やDelphiの場合は「//」を指定します。 スクリプト系の場合は、「;」などの場合もあります。 行頭でしか作用しないのオプションを使うと、 その文字が行頭または、 その前にスペースかタブのみがある場合のみにコメント文字として認識されます。

    一組だけしか設定できません。

  • コメントセット文字列

    コメントを表す対になる文字列を設定します。 左の文字列と右の文字列をセットで表します。 たとえば、C言語の場合は、「/*」と「*/」を設定します。 Delphiの場合は、「{」「}」のセットと、「(*」「*)」のセットを設定します。 新規作成やプロパティで表示させる コメントセット文字列のプロパティで、 そのコメントセット文字列で囲まれた部分を、 どういう文字種で表示するかを選択することもできます。

    Cの場合、「#ifdef 0」と「#endif」を設定すると、 この組でコメントアウトする場合は便利です。ただしコメントの中に、 #endifが一度でも出るとコメントが閉じられてしまいますから、 うまく行かない場合もあります。


ファイルタイプ別の設定－関連づけのページ

関連づけのページ

K2Editorのタイプ別の拡張子設定の変更と、 Windowsに対してファイルの関連づけ設定を行います。

  • 関連づけられている拡張子

    K2Editorで、選択されているファイルタイプで開くファイルの拡張子が表示されます。

  • 追加ボタン

    拡張子を手動で追加します。通常は、K2Editorでファイルを開いて、 ファイルタイプごとの設定でファイルタイプを選択しOKを押せば、 自動的に追加されます。

  • 削除ボタン・編集ボタン

    選択された拡張子を削除したり、変更したりします。 通常は特に使うことはないでしょう。

  • ウィンドウズに対する関連づけ

    このページの右側では、 ウィンドウズに対してファイルの関連づけ設定を行うことができます。

    • 関連づけとして登録ボタン

      このボタンを押すと、 拡張子ボックスに入力されている拡張子を、 ウィンドウズの関連づけとして登録します。 その拡張子を持ったファイルをダブルクリックすることで、 K2Editorで開くことができるようになります。

    • 拡張子ボックス

      ウィンドウズに対して関連づける拡張子を入力します。コンマから入力してください。 （例：「.txt」）

    • 関連づけに使用するK2Editorオプション

      ファイルをダブルクリックしてK2Editorで開くとき、 K2Editorに対して指定するオプションを入力します。 オプションについては、 「起動オプション」を参照してください。

    • 関連づけに使用するファイルタイプ名

      エクスプローラで、そのファイルの種類のカラムに表示される名前を入力します。

    • 標準の操作

      ここにチェックを入れると、 そのファイルタイプに対して複数のアプリケーションが登録されているときに、 K2Editorを優先的に使用するようにします。

    • ファイルのアイコンも変更

      ここにチェックを入れると、エクスプローラで表示されるそのファイルのアイコンが、 K2Editorのアイコンになります。


キーワード強調表示とカラー化

K2Editorは、非常に強力なキーワード検索機能と、 カラーカスタマイズ機能を搭載しています。 この章では、その使い方を例をとって解説します。

  • 強調表示とは
  • 12種の強調文字種とコメント
  • キーワード設定をするには


キーワード強調表示とカラー化－強調表示とは

強調表示とは

K2Editorでは、キーワードを登録し、そのキーワードの表示形式を設定することによって、 各種色分けやフォントスタイルの変更を行うことができます。

このように、各種キーワードを色分けすることにより、視認性が高まり、 間違いが起こりにくくなる作用もあります。 まぁ、難しいことを言わなくても、見ていて楽しいだけで十分ですね。

色分けすることで、K2Editorのパフォーマンスは若干下がります。 スクロール速度が少し落ち、編集するときにちらつきが起きます。 キーワードを増やしすぎると顕著になるので、K2Editorの特徴をよく知って、 最大のパフォーマンスと見やすさを両立させるようにしてください。

キーワードの設定は、ファイルタイプ別設定－ キーワードのページで設定できます。


キーワード強調表示とカラー化－12種の文字種とコメント

12種の文字種とコメント

K2Editorでは、強調表示は6種の装飾設定を持ち、 別に行全体を装飾する行強調も6種類持ちます。 これとは別にコメントという文字種も持ちます。

これらの文字種は、すべて独立に色とフォント装飾を設定できます。

これらを、設定したキーワードに関連づけることによって、 各キーワードに装飾をすることができます。

色の設定は、 ファイルタイプ別設定－色のページで設定できます。


キーワード強調表示とカラー化－キーワード設定をするには

キーワード設定をするには

キーワード設定をするのは、結構面倒です。 K2Editorのアーカイブには、いくつかキーワードファイル（*.hil）が入っていますから、 これが使えればラッキーです。 幸い、K2Editorでは秀丸のハイライトファイルが使えますから、 これを手に入れるのも一つの方法です。

これで満足できない場合、自分で設定を行う必要があります。 一気に設定するのが面倒な場合は、色をつけたいキーワードが出てきた時点で、 一つずつ設定していくといいかもしれません。

K2Editorの特徴として、キーワードの数が多いとパフォーマンスが悪くなりますので、 100個程度を目安として、できるだけ少ないキーワードの数で、 効果的な色設定を行うようにしましょう。 たとえば、まとめられるキーワードは正規表現を使って一つにまとめた方が、 描画速度は速くなります。

キーワード一覧で、上にあるキーワードほど、後から描画します。 つまり上書きして描画します。これを使うと、より細やかな色指定ができます。 これは、同梱されているHTML.hilなどで使われている手法です。 より高度な色分けがしたい人は、 この辺でどういう風に指定しているか調べてみてください。


整形

日本語整形

K2Editorの大きな特徴として、整形機能があります。 メールなどで日本語文書を書くとき、 適当な桁数で改行コードを挿入する必要があります。 これを簡単にかっこよくやる機能です。

K2Editorの整形は、以下のような特徴を持っています。

  • 句読点入力をトリガーとする、自動整形機能
  • 段落を指定しなくても段落を推測して整形する、インテリジェント整形
  • 半角英単語が日本語の中に出てくる場合、前後に半角空白を挿入する、空白補完
  • インデント整形
  • 箇条書き整形
  • 段落を指定して整形する、範囲整形
  • コメント整形
  • コメント分割

簡単に使用するには、ファイルタイプごとの設定の入力・移動のページで、 自動整形にチェックを入れて、その後日本語を入力してください。 句読点を入れるたびに整形機能が働いて、74桁で自動的に改行が挿入されます。 またデフォルトのキーマップでは、SHIFT+ENTERに整形が割り当てられています。 日本語を入力しながら時々SHIFT+ENTERを押すと、その都度整形が実行されます。

  • 整形と段落
  • 自動整形
  • 範囲整形
  • インデント整形
  • コメント整形
  • 箇条書き整形
  • スペース補完
  • 行の分割


整形－整形と段落

整形と段落

テキストエディタで日本語を入力するとき、適当な桁数で改行を行って、 データを扱いやすくする場合があります。たとえば、 インターネットメールを書くとき、 80桁以内で改行を入れることがマナーであると一般的に言われています。 相手の人が自分の文書を引用するときのことを考えると、 74桁くらいで改行コードを入れ、 引用符を追加する余裕を持たせてあげるのがいいでしょう。

------------------------------------------------------------
これが整形された文書です。60 桁で改行を入れる設定にして、整形
をしながら入力されました。改行を入れないで文書を入力すると、
１行が長くなって、コンピュータで扱いにくくなります。また手動
で改行を入れると、桁数を数えて改行を入れて行かなくてはならな
いので、かなり面倒です。

これが次の段落です。段落が変わることを示す場合、いろいろな方
法があります。空行を入れる、段落の最初を全角空白で始めるなど、
自分のスタイルを決めておくとよいです。
------------------------------------------------------------

上記の文章で、整形桁を56桁にして、先頭行にカーソルを置き、 整形コマンドを実行すると、上の段落を一気に整形して、１行を56桁にします。

------------------------------------------------------------
これが整形された文書です。60 桁で改行を入れる設定にして、
整形をしながら入力されました。改行を入れないで文書を入力
すると、１行が長くなって、コンピュータで扱いにくくなりま
す。また手動で改行を入れると、桁数を数えて改行を入れて行
かなくてはならないので、かなり面倒です。

これが次の段落です。段落が変わることを示す場合、いろいろな方
法があります。空行を入れる、段落の最初を全角空白で始めるなど、
自分のスタイルを決めておくとよいです。
------------------------------------------------------------

しかし、50桁設定で整形を行うと、段落を一気に整形を行ってくれません。

------------------------------------------------------------
これが整形された文書です。60 桁で改行を入れる設定に
して、整形
をしながら入力されました。改行を入れないで文書を入力すると、
１行が長くなって、コンピュータで扱いにくくなります。また手動
で改行を入れると、桁数を数えて改行を入れて行かなくてはならな
いので、かなり面倒です。

これが次の段落です。段落が変わることを示す場合、いろいろな方
法があります。空行を入れる、段落の最初を全角空白で始めるなど、
自分のスタイルを決めておくとよいです。
------------------------------------------------------------

これは、その行の文字数が、整形桁数よりも 6 半角文字以上違う場合、 整形範囲を拡張しないためです。この場合でも、カーソルを行末に置くと、 整形範囲を次の行に拡張してくれます。上記の１行だけ整形された状態では、 カーソルは行末に移動しているので、そのまま整形を連続実行すれば、 １段落分の整形が完了します。

------------------------------------------------------------
これが整形された文書です。60 桁で改行を入れる設定に
して、整形をしながら入力されました。改行を入れない
で文書を入力すると、１行が長くなって、コンピュータ
で扱いにくくなります。また手動で改行を入れると、桁
数を数えて改行を入れて行かなくてはならないので、か
なり面倒です。

これが次の段落です。段落が変わることを示す場合、いろいろな方
法があります。空行を入れる、段落の最初を全角空白で始めるなど、
自分のスタイルを決めておくとよいです。
------------------------------------------------------------

空行が入っていると、その次の行には整形範囲を広げません。 次の段落にカーソルを移動してから整形を実行してください。

------------------------------------------------------------
これが整形された文書です。60 桁で改行を入れる設定に
して、整形をしながら入力されました。改行を入れない
で文書を入力すると、１行が長くなって、コンピュータ
で扱いにくくなります。また手動で改行を入れると、桁
数を数えて改行を入れて行かなくてはならないので、か
なり面倒です。

これが次の段落です。段落が変わることを示す場合、い
ろいろな方法があります。空行を入れる、段落の最初を
全角空白で始めるなど、自分のスタイルを決めておくと
よいです。
------------------------------------------------------------

整形範囲が次の行に拡張されない条件には、以下のものがあります。

  • 行の文字数が、整形桁数±6 文字の範囲に入っていない場合（行末にカーソルがある場合をのぞく）
  • 次の行頭が全角スペースの場合
  • 次の行が空行の場合
  • 現在の行がコメント行でなくて、次の行がコメント行の場合
  • 現在の行がコメント行で、次の行がコメント行でない場合
  • 次の行が箇条書きのはじめの行の場合


整形－自動整形

自動整形

K2Editorには、句読点などの文字を入力すると、自動的にその行と、 その下の段落だとみなした行に対して整形を行う、自動整形機能があります。 自動整形を行った後、カーソル位置は入力位置をキープするので、 そのまま入力を続けていくことができます。たとえば、 あらかじめ入力された文書の途中に追記するときなど、 句読点を入れると、自動的に整形され、そのまま次の追記を続けることができます。

自動整形を設定するには、ファイルタイプ別設定の、 「入力・移動のページ」で、 句読点によって整形を行うにチェックを入れてください。 また、そのページの整形のトリガーに、 入力されたら自動整形を行う文字を入力します。

自動整形桁に縦線を入れるにチェックを入れて、 適当に色を設定すると、編集ウィンドウ内に、縦線が描かれます。 ただし、整形では、ぶらさげ処理などで、 必ずしもその線で改行が入るわけではありません。 あくまでも目安です。

さて、設定を行ったら、文書を入力してみましょう。整形桁を越えて入力し、 句読点を入力すると、自動的に改行が入れられます。 どこまでを整形段落とみなすかは、通常の整形と同じルールが適用されます。 ルールについては、整形と段落を参照してください。


整形－範囲整形

範囲整形

選択した状態で整形コマンドを実行することで、 その選択範囲を段落として整形を行います。 これを範囲整形といいます。

通常の整形では、 段落認識のルール（整形と段落参照）が適用されますが、 範囲選択を行って整形を行えば、このルールを越えて段落整形することができます。

ただし、複数の段落を選択して整形すると、１段落と考えて整形してしまうので、 注意してください。


整形－インデント整形

インデント整形

行頭に半角空白やタブを入れて文書を入力し、整形を行うと、 整形段落全体にインデントが挿入されます。これをインデント整形といいます。 日本語文書を入力していて、インデントを入れたい場合、この機能が有用です。

ファイルタイプごとの設定の入力・移動のページで、 全角スペースでもインデントするにチェックが入っていると、 全角空白もインデントとみなします。ただし、 入力した全角空白は半角空白に置き換わります。


整形－コメント整形

コメント整形

メールの文書などを入力している場合、 相手のメールにコメントを付ける場合があります。 引用符を行頭につけ、相手の文章を引用するのが慣習です。 この時、相手の文章の１行行数があまりにも長い場合、 取り扱いに困る場合があります。 こういう場合、コメント整形機能を使うと便利です。

コメント整形を使う場合、 共通設定の整形のページの コメント整形にチェックを入れるか、 整形の一時設定コマンドを使用して、 コメント整形をオンにしておく必要があります。

その状態で、以下のような文章を整形してみましょう。

> これはコメント整形のテストの文章です。一行文字数をちょっと長めにしてみましょう。
> これはコメント整形のテストの文章です。一行文字数をちょっと長めにしてみましょう。
> これはコメント整形のテストの文章です。一行文字数をちょっと長めにしてみましょう。
> これはコメント整形のテストの文章です。一行文字数をちょっと長めにしてみましょう。

この文章に対して、74桁で整形を行います。 最初の行にカーソルを置いて、整形を連続して行うか、範囲整形を行ってみましょう。

> これはコメント整形のテストの文章です。一行文字数をちょっと長めにしてみま
> しょう。これはコメント整形のテストの文章です。一行文字数をちょっと長めに
> してみましょう。これはコメント整形のテストの文章です。一行文字数をちょっ
> と長めにしてみましょう。これはコメント整形のテストの文章です。一行文字数
> をちょっと長めにしてみましょう。

このように、コメント文字が行頭に置かれて、なおかつ整形が行われます。

コメント整形でその行がコメントだと認識される文字は、 一般設定の整形のページで設定します。 必ず正規表現の行頭を表す「^」から始めるようにしてください。

Ｃ言語のソースなどでは、//で始まる行はコメントとして扱われます。 整形のコメント文字に"^//[ \t]*"を設定しておくと、 コメントを整形しながら書くことができます。 通常、プログラム言語ソースでは、整形は行わないので、 「コメント整形のみ行う」にチェックを入れておくと、 コメントを書いているときだけ整形を働かせることができます。


整形－箇条書き整形

箇条書き整形

先頭を箇条書き文字で始めた行で整形を行うと、箇条書き整形を行います。

・これは箇条書きの行です。ちょっと長めに書いてみましょう。もうちょっともうちょっと。

ここで、整形を行うと……

・これは箇条書きの行です。ちょっと長めに書いてみましょう。もうちょっともう
  ちょっと。

となります。このように箇条書き文字を前に出して、整形することができます。

箇条書きが終わったところで、行の分割コマンドを行うと、 箇条書き文字を先頭に補いながら改行します。

◎これは箇条書きです。この行の途中にカーソルを置いて、行の分割を行ってください

この行の途中で行の分割を行うと、

◎これは箇条書きです。
◎この行の途中にカーソルを置いて、行の分割を行ってください

となります。なお、行末で行の分割を行うと、

◎これは箇条書きです。この行の途中にカーソルを置いて、行の分割を行ってください
◎

となって、次の箇条書きを書くことができます。


整形－スペース補完

スペース補完

整形を行う際に、スペース補完オプションをオンにしていると、 半角文字で書かれた単語の両端に半角スペースを補って読みやすくします。 この機能を働かせるには、 共通設定の整形のページで、 スペース補完にチェックを入れておく必要があります。 たとえば……

この行を整形するとwordの前後にスペースが補完されます。

という行に対して整形を行うと、

この行を整形すると word の前後にスペースが補完されます。

となって、多少読みやすくなります。まぁ、お好みですが……

ただし、スペースを補完したくない特別な文字があるとします。 たとえば、2000年1月1日という文字列に整形を行うと、何も指定がなければ、

2000 年 1 月 1 日

となって間が抜けてしまいます。 左側にスペースを補完しない文字列の中に「年月日」を指定しておくと、

2000年 1月 1日

となり、読みやすくなります。（まぁこれも好みですが）

「年月日」はデフォルトで指定されています。

同様に、右側にスペースを補完しない文字列を設定することもできます。


整形－行の分割

行の分割

「行の分割」機能は、デフォルトで CTRL+ENTER に割り付けられています。

たとえば、

> あっそうか、 これも NIFTY 慣用表現の一つなんですね。RE: が何を意味
> するかという論争も読んだことがありましたっけ。なんだか、ラテン語の
> なんたらかんたらとかって話にまでなってましたっけ。

という文章があったとして、「なんだか～」以降で分離したいとします。 普通に分離すれば、

> あっそうか、 これも NIFTY 慣用表現の一つなんですね。RE: が何を意味
> するかという論争も読んだことがありましたっけ。
なんだか、ラテン語の
> なんたらかんたらとかって話にまでなってましたっけ。

となってしまって、行頭にコメント文字を手動で挿入しなければなりません。 ここで、行の分割を使ってみます。分離したい部分にカーソルを置いて、 行の分割をすると、

> あっそうか、 これも NIFTY 慣用表現の一つなんですね。RE: が何を意味
> するかという論争も読んだことがありましたっけ。
> なんだか、ラテン語の
> なんたらかんたらとかって話にまでなってましたっけ。

となります。コメントを分断するときに便利な機能です。

また

    ・これは箇条書きの文です。これは箇条書きの文です。これは箇条書きです。

という文の途中でぶちぎる時、普通に改行を入れると、

    ・これは箇条書きの文です。これは箇条書きの文です。
    これは箇条書きです。

となりますが、行の分割を使うと

    ・これは箇条書きの文です。これは箇条書きの文です。
    ・これは箇条書きです。

となります。このまま行末に移動して整形を実行すれば、 箇条書きがフォーマットされます。

なお、この機能は、箇条書きを書いていて、次の行に移るときにも有効です。たと えば、

    ・これは箇条書きの文です

という箇条書き文を書いていて、次の箇条書きを書きたい場合、 行末で「行の分割」を実行します。すると、

    ・これは箇条書きの文です
    ・

となって、次の箇条書きを入力ができます。ただし、数字などを使っている場合、 その数字を進めてくれる機能はないので、手動で進めてください。

    (1) これは箇条書きです
    (1)


常駐

K2Editorは、常駐することができます。 常駐とは、タスクトレイにアイコンを表示することを言います。 そこからK2Editorを起動したり、GREPを行ったりできます。

常駐を行うには、常駐の方法を見てください。

常駐すると、タスクトレイにアイコンが表示されます。 このアイコンをダブルクリックすると、新しいK2Editorが開きます。 また右クリックすると、ポップアップメニューが開いて、 ファイルの履歴からK2Editorを開いたり、GREPなどを起動することができます。

常駐を終了するには、 タスクトレイのアイコンを右クリックして、常駐終了を選択してください。

K2Editorは、常駐をしなくても、裏に１枚余分なK2Editorを立ち上げています。 この裏K2Editorは、K2Editorが１枚もなくなると終了します。 常駐は、これをタスクトレイに表示して、常に起動しておくことを指します。 １枚目の起動が多少速くなります。


常駐－常駐の方法

常駐の方法

常駐をさせるには、次の２つの方法があります。

  • 共通設定の一般設定のページ で、常駐するにチェックを入れる

    最初にK2Editorを立ち上げた時に、常駐します。

  • 常駐用のショートカットを作って、スタートアップフォルダに入れる

    起動オプションの/Aを使って、 K2Editorのショートカットに/Aを指定しておくと、 常駐するためのショートカットを作ることができます。 これを、Windowsのスタートアップフォルダに入れると、 Windowsの起動時に常駐させることができます。


常駐－ポップアップメニュー

常駐のポップアップメニュー

常駐アイコンを右クリックすると、ポップアップメニューが開きます。

  • 新規作成

    新しいK2Editorを開きます

  • 開く

    ファイルオープンダイアログを開き、ファイルをK2Editorで開くことができます。

  • ファイル履歴

    K2Editorで最近開いたファイルが一覧されます。ここに表示される個数は、 共通設定の一般設定のページで、 「常駐時のファイル履歴の個数」を設定します。

  • 縦に並べる

    開いているK2Editorで最小化されていないものを縦に並べます。

  • 横に並べる

    開いているK2Editorで最小化されていないものを横に並べます。

  • 重ねて表示

    開いているK2Editorで最小化されていないものを重ねて並べます。

  • 並べて表示

    開いているK2Editorで最小化されていないものを格子状に並べます。

  • 全部最小化

    開いているすべてのK2Editorを最小化します。

  • 全終了

    開いているK2Editorをすべて終了します。

  • 常駐終了

    常駐アイコンを消去して、常駐を解除します。


クリッカブルオブジェクト

クリッカブルURLなど

K2Editorでは、URL・EMAILアドレス・Fileなどが文書中に出てきた場合、 その部分をマウスでダブルクリックすると、それらをOSに渡して開く機能を持っています。 URLではブラウザが開き、EMAILアドレスでは、メーラーを開きます。 Fileでは、そのファイルが関連づけられたアプリケーションで開きます。

これらを使用するには、 ファイルタイプ別設定の表示のページで、 URLなどの各タイプにチェックを入れておく必要があります。

各オブジェクトの装飾は、ファイルタイプ別設定の 色のページでそれぞれ個別に変更できます。

  • URL
  • E-Mailアドレス
  • FILE
  • NIFTY-URL


クリッカブルオブジェクト－URL

URL

http://から始まる語句は、URLとして認識されます。ちょうどブラウザ上で、 「http://web.kyoto-inet.or.jp/people/koyabu/」 と表示されるのと同じ感じです。

これをダブルクリックしたときに、どのアプリケーションで開かれるかは、 エクスプローラで設定します。 エクスプローラの表示－オプションなどを選択すると、 ファイルタイプを設定するページがあります。 そこで、HTML DOCUMENTの項目を変更します。 OSによって操作が変わりますので、 詳しくはその手の文献やWebでの情報を参考にしてください。


クリッカブルオブジェクト－E-Mailアドレス

E-Mailアドレス

E-Mailアドレスが文書中に出てきた場合、ダブルクリックすると、 メールクライアントが開いて、メールを送信できる状態になります。 ただし、Windowsの設定が適切に行われている必要があります。

エクスプローラの表示－オプションのファイルタイプ設定で、 「URL:MailToプロトコル」が適切に設定されている必要があります。 ご使用のメールクライアントソフトで設定方法が説明されていると思います。 そちらを参照してください。


クリッカブルオブジェクト－FILE

FILE

Fileオブジェクトは、「file://」で始まる語句です。これで始まる語句は、 ファイルだと認識されます。これをダブルクリックすると、 そのファイルを関連づけられたアプリケーションで開くことができます。 file://以下は、漢字などの２バイト文字もファイル名だと認識されてしまいます。 これを避けるためには、ダブルコーテーションで囲んでください。

file://"C:\MyDocument\日記.txt"

このように表記すると、 ダブルコーテーションで囲まれた部分をファイル名だと認識します。

このオブジェクトをOSに渡すとき、「file://」ごと渡します。 この文字列は、インターネットエクスプローラによって解釈され、 ファイルを開くことができます。
ファイルはWindowsによって、拡張子で判断され、適切なアプリケーションで開きます。 どのアプリケーションで開くかの設定は、エクスプローラの開く－オプションあたりの、 ファイルタイプの設定で行います。OSの種類によって異なりますので、 別の文献やWebなどを参照してください。


クリッカブルオブジェクト－NIFTY-URL

NIFTY-URL

NIFTY SERVEのログは、NIFTY-URLと呼ばれるポインタで示すことができます。 これは、nifty:ではじまる語句です。

これを利用するには、拙作WithNIFTYをインストールしているか、 他のNIFTY通信ソフトを持っていて、なおかつそれがK2Editorに対応している、 または対応しているプラグインがあるなどの条件があります。

詳しくは、各通信ソフトのコミュニティーに問い合わせてください。


マーク

マークとは、K2Editorで開いている文書のある行に印をつけ、 ワンタッチで、その印を検索したり、一覧を見たりできます。 また、K2Editorには、番号付きマークという機能もあり、 このマークは、0～9までの番号を持ち、それぞれのマークを指定して印をつけたり、 ジャンプしたりできます。

マークは、ファイル履歴と一緒に保存されますので、 最近開いた30個のファイルについては、マークを覚えています。

  • 通常マーク
  • 番号付きマーク
  • マーク一覧ダイアログ


マーク－通常マーク

通常マーク

通常マークは、現在行のマーク／マーク解除コマンドを使って、 つけたり消したりします。デフォルトでは、CTRL+Mに割り付けられているので、 マークしたい行で、CTRL+Mを押すと、左マージン内にマークをつけた印がつきます。

通常マークは、マーク行の上検索と マーク行の下検索のコマンドを使用して移動します。 これらのコマンドはデフォルトで、CTRL+UP/DOWNに割り付けられています。

また、マーク一覧ダイアログ を表示してジャンプすることもできます。マーク一覧は、 デフォルトではSHIFT+CTRL+Mに割り付けられています。

マークされているファイルを編集すると、一応、編集に応じて、マーク位置を移動します。 ただ、マークされている行のどこかに改行を挿入すると、マークは一行下に移動します。 これは仕様です。


マーク－番号付きマーク

番号付きマーク

通常マークと違い、番号付きマークは、各マークに番号がついていて、 ジャンプしたいマークを直接指定してマークできます。 ０～９までのマークが使えます。

マークをするには、マークＸを設定コマンドを使います。 デフォルトでは、SHIFT+CTRL+[0-9]に割り付けられています。 ある行に０番のマークをつけ、別の行に、同じく０番のマークをつけると、 前につけたマークは削除されます。また０番のマークの行で、 マーク０を設定コマンドを行うと、０番のマークが消えます。

番号付きマークに移動するには、マークＸに移動コマンドを使用します。 デフォルトでは、CTRL+[0-9]に割り付けられています。 その番号のマークに直接ジャンプすることができます。 また、通常マークと同じく、マークの上・下検索コマンドでも移動できます。

マーク一覧ダイアログにも表示されますので、 ここからジャンプすることもできます。


マーク－マーク一覧ダイアログ

マーク一覧ダイアログ

このダイアログは、マーク一覧コマンドを選択したときに表示されます。

左にマーク一覧、右に制御用のボタンが並びます。 マーク一覧は、左から、マーク記号、 マークされいてる行数、 その行の内容が表示されています。

ボタンは以下のものがあります。

  • ジャンプ

    選択したマークにジャンプします。

  • マーク

    現在カーソルのある行にマークをつけます。既にマークが着いている場合は削除します。

  • 削除

    選択されたマークをクリアします。

  • すべてクリア

    マーク一覧に表示されているすべてのマークを削除します。

  • 番号マーククリア

    番号付きマークをすべてクリアします。

  • 通常マーククリア

    通常マークをすべてクリアします。


検索と置換

検索機能と置換機能について説明します。

K2Editorでは、開いている文書内で、 特定の文字列を検索したり、 別の文字列に置換したりできます。

検索パターンに正規表現が使えますので、 多彩な検索パターンを指定することが可能です。

正規表現については、README.JREを参照してください。
K2Editor では、正規表現検索についての制約事項があります。
  • 改行は \n のみでマッチ。\r ではマッチしない
  • 改行コード \n を入れたとき、２行まとめて検索する。２行以上に対しての検索はサポートされていない
  • \n と $ を同時に使ったときの動作は保証しない。
これらの制約は、K2Editor が正規表現検索エンジン JRE32.DLL を使う場合の制約であって、JRE32.DLL 自体の問題ではありません。

検索や置換を行った後、下候補・上候補コマンドを使うと、 次の候補にジャンプすることができます。置換の場合は、 その文字を置換するかどうかを問い合わせます。

検索をすると、検索語すべてを装飾します。装飾するかどうかは、 共通設定の一般設定のページで、 検索文字を色分けするにチェックを入れるかどうかで、 設定できます。また装飾の方法は、ファイルタイプ別設定の、 色のページで設定することができます。

一旦検索や置換した後、色分けをやめたいときは、 検索語のクリアコマンドを使用してください。

  • 検索ダイアログ
  • 置換ダイアログ


検索と置換－検索ダイアログ

検索ダイアログ

検索コマンドを選択すると、検索ダイアログが表示されます。

  • 検索語

    検索する語句を指定します。正規表現も使えます。

    正規表現については、README.JREか、 他の文献を参考にしてください。
  • 大文字・小文字の区別

    チェックを入れると、半角英文字の大文字小文字を区別します。 全角の英文字には効果がありません（常に大文字と小文字を区別します）

  • 単語の検索

    単語を検索します。ただし、K2Editorの仕様では、「#」などのシンボルは、 単語として独立してしまいますので、「#Include」などをマッチさせたい場合は、 ここにはチェックを入れないでください。

  • 正規表現

    検索語に正規表現を使うかどうかを設定します。 正規表現については、README.JREを参照してください。 正規表現にチェックを入れると、常に大文字と小文字は区別されます。 またあいまい検索が使えるようになります。

  • あいまい検索

    正規表現を使用すると、この設定を使うことができます。あいまい検索は、 検索語の全角と半角を区別しません。

  • 上検索と下検索

    ボタンを押すと、カーソルより上を検索するか、 下を検索するかを選択することができます。

  • ファイル先頭から

    ここにチェックを入れると、一旦カーソルをファイル先頭に移動してから、 検索を始めることができます。


検索と置換－置換ダイアログ

置換ダイアログ

置換コマンドを選択すると、検索ダイアログが表示されます。

  • 検索語

    ここに検索語を指定します。

  • 置換する語

    マッチした検索語を、ここに指定した語に置換します。

    正規表現を使用する場合は、「\」は予約語になります。「\n」で改行、 「\t」でタブを表します。「\」そのものを置換語に使いたい場合は、 「\\」と指定してください。

  • 大文字・小文字の区別

    チェックを入れると、半角英文字の大文字小文字を区別します。 全角の英文字には効果がありません（常に大文字と小文字を区別します）

  • 単語の検索

    単語を検索します。ただし、K2Editorの仕様では、「#」などのシンボルは、 単語として独立してしまいますので、「#Include」などをマッチさせたい場合は、 ここにはチェックを入れないでください。

  • 正規表現

    検索語に正規表現を使うかどうかを設定します。 正規表現については、README.JREを参照してください。 正規表現にチェックを入れると、常に大文字と小文字は区別されます。 またあいまい検索が使えるようになります。

  • あいまい検索

    正規表現を使用すると、この設定を使うことができます。あいまい検索は、 検索語の全角と半角を区別しません。

  • 上検索と下検索

    ボタンを押すと、カーソルより上を検索するか、 下を検索するかを選択することができます。マッチしたら、 置換するかどうかを選択できます。

  • ファイル先頭から

    ここにチェックを入れると、一旦カーソルをファイル先頭に移動してから、 検索を始めることができます。

  • 連続置換

    下検索を連続的に行います。置換するかどうかを選択したら、 自動的に次の語を検索します。

  • 全置換

    カーソル以降のすべての検索語を置換します。 やり直しはできません。


マクロ

K2Editorには、簡単なマクロが登載されています。

ユーザーが行う操作を記憶し、それを再生することで、 繰り返し操作を簡単にすることのが基本的な使い方です。 たとえば、ある範囲の行頭に">"を追加する場合、普通の操作なら、

  • 行頭に移動
  • >を挿入
  • 下の行に移動

という動作を繰り返す必要があります。この動作を記録し、再生をすれば、 ３つの手順を一度に行うことができます。 これがキーマクロとしての使い方です。

K2Editorのマクロ機能では、記憶したマクロをファイルに保存することができます。 このファイルを読み込めば、いつでも作成したマクロを使うことができます。

また、割り当てマクロとしてファイルに落としたマクロを登録すれば、 読み込みの動作を必要とせず、ワンタッチでマクロを再生できます。

カーソル直前のマクロを実行コマンドを使用すると、 K2Editorに入力した文字列から外部マクロをサーチし、実行します。

マクロは、直接ファイルに記述することもできます。

  • キーマクロの使い方
  • キーマクロの保存
  • 外部マクロ実行
  • 割り当てマクロ
  • カーソル直前のマクロを実行
  • マクロを記述する


マクロ－キーマクロの使い方

キーマクロの使い方

エディタで編集をしていると、同じ動作を何度も繰り返さなければいけない場面に、 よく出くわします。そういう時、いろいろと工夫をして、 簡単な操作でできるように考えるのは面倒なものです。 ついつい全部まじめに動作を繰り返してしまいます。 しかし、そういう動作を一日中やっていると、 だんだんボディーブローのように指に負担をかけていきます。

こまめにキーマクロが使えるかどうかを考えて、 できるだけ使っていきましょう。

たとえば、以下のような表があるとします。

1234567890
2345678901
3456789012
4567890123

ここに、頭から３桁ごとにカンマを入れる仕事があるとしましょう。 どうしますか？ ４行だから、手作業で入れることも可能です。でも、こういう単純作業で、 キーマクロは威力を発揮します。

最初の１行にカンマを入れる作業を行ってみましょう。 最初の１行の行頭にカーソルがあると仮定すると……

  • ３回右矢印を押す
  • カンマ入力
  • ３回右矢印を押す
  • カンマ入力
  • ３回右矢印を押す
  • カンマ入力

という動作を繰り返せば、

123,456,789,0

とすることができます。で、これをやる前に、 マクロ記録開始／終了コマンドを行います。 すると、K2Editorの最上部のタイトルバーに[★記録中]という表示が出ます。 そのまま、上述の動作を行い、次が肝心ですが、その後、一つ下にカーソルを移動し、 行頭に飛びます。そして最後にマクロ記録を終了します。 ここまでのキー操作を書き出してみると……

  • SHIFT+F1（マクロ記録開始）
  • →（３回）
  • ,
  • →（３回）
  • ,
  • →（３回）
  • ,
  • ↓
  • HOME（行頭移動）
  • SHIFT+F1（マクロ記録終了）

ここまでやったら、そのままSHIFT+F2を押して、 マクロを再生してみましょう。 今記録したキー操作が再生されて、 次の行にも同じように３桁ごとのカンマが入れられたと思います。

では、前述の表に、通常のお金につけるカンマのように、 後ろからカンマを入れないといけないとしたらどうでしょう。 この場合は、後ろから３桁ずつ左にずれながらカンマを入力すればいいですね。

  • SHIFT+F1（マクロ記録開始）
  • END（行末移動）
  • ←（３回）
  • ,
  • ←（４回）
  • ,
  • ←（４回）
  • ,
  • ↓
  • HOME（行頭移動）
  • SHIFT+F1（マクロ記録終了）

これで、後ろから３桁ずつカンマを入れるマクロを記録することができました。 このマクロでは、最後に行頭に飛んでいますが、もちろん行末に飛んでも構いません。 その場合、行末からマクロ実行をはじめることを忘れなければ、 １つ目の動作の行末移動を省くことができますね。

もし、この動作を100回繰り返さなければならないとしたら、 このマクロは強力な武器になります。

キーマクロを使うには、ちょっとした考え方のこつがあります。たとえば、 常に行頭を基準にした動作をするように心がけることとかです。 これは、使っていくうちに慣れていくものですから、 最初のうちは失敗することもあるかもしれませんが、恐れずに使ってください。 アンドゥすれば元に戻せるので、安心してやってください。

キーマクロは、キー操作を覚えているのではなくて、 内部で実行されたコマンドを覚えています。だから、 メニューやツールバーからコマンドを実行しても記録されます。


マクロ－キーマクロの保存

キーマクロの保存

記録したキーマクロは、ファイルに保存することができます。 マクロを記録したら、記録の保存コマンドを使用してください。 保存するファイルを指定して、 K2Editor起動フォルダの下のMacroフォルダに保存してください。 拡張子は、「.mac」にしてください。保存を行うと、 説明を入力するように求められるので、そのマクロの簡単な説明を入力してください。

記録したマクロを実行するには、 外部マクロ実行を見てください。


マクロ－外部マクロ実行

外部マクロ実行

ファイルに保存したマクロを実行するには、２通りの方法があります。 外部マクロ実行コマンドと、 外部マクロ読み込みコマンドを使う方法です。

マクロをキーに割り当てる方法もありますが、 それは割り当てマクロを参照してください。

  • 外部マクロ実行

    外部マクロ実行コマンドを選択すると、 キーマクロ一覧ダイアログが現れます。 ここで、マクロを選択して、実行できます。

  • 外部マクロ読み込み

    外部マクロ実行と同じように、キーマクロ一覧ダイアログが開きますが、 ここでマクロを選択しても実行されません。内部のキーマクロとして記憶されるので、 その後は、マクロ再生コマンドで実行してください。 何度も実行できる利点があります。


マクロ－マクロ割り当て

マクロ割り当て

ファイルに保存した外部マクロは、マクロ1～10として、 内部マクロとほぼ同じように登録することができます。 これを、キーに割り付けると、 10個のマクロを通常コマンドのようにして使用できます。

外部マクロを割り当てるのは、 共通設定のマクロのページで行います。 これらのマクロは、 外部マクロXの実行コマンドを使用して呼び出せます。 デフォルトでは、CTRL+F1～F10に割り付けられています。


マクロ－カーソル直前のマクロを実行

カーソル直前のマクロを実行

このコマンドは、K2Editorに外部マクロファイル名を入力し、 それを実行する機能です。 デフォルトでは、CTRL+SPACEに割り付けられています。

たとえば、次のようなマクロを記録してみましょう。

<UL>
<LI>
</UL>

この文字列を入力した後、カーソルを<LI>の後ろに移動してください。 その後、マクロの記録を終了します。

これは、HTMLで箇条書きを書くためのタグです。 <LI>の後ろに各個条書きの文書を書きます。

これを、記録の保存コマンドで、 ul.macというファイル名で保存します。

ここまで終わったら、K2Editor を開いて、行頭に ul と入力し、 CTRL+SPACE を打ってみてください。先ほど書いた文字列が入力されて、 カーソルが <LI> の後ろに移動していれば成功です。 最初に打ち込んだ ul という文字列は、このマクロを実行する際に削除されました。

このコマンドでファイルを探す場合、 インクリメンタルサーチという手法が使えます。 たとえば、Macro フォルダの中に、f から始まる外部マクロが、 funfun.mac しかなかったとしたら、f を入力し CTRL+SPACE を打つと、 funfun.mac が実行されます。

ただし、finfin.mac も Macro フォルダに入っていると、 f を入力しただけでは、CTRL+SPACE をたたいても実行されません。 この場合は、実行するマクロが確定するfuまで入力して、実行してください。


マクロ－キーマクロ一覧ダイアログ

キーマクロ一覧ダイアログ

このダイアログは、マクロを実行するときや、マクロを読み込む時などに開かれます。

  • マクロ名

    マクロ名を入力します。ここに文字を入力すると、インクリメンタルサーチが行われ、 マクロが確定するまで文字を入力すると、マクロ一覧でそのマクロが選択され、 実行や読み込みができるようになります。

  • マクロ一覧

    K2Editorの実行フォルダの中のMacroフォルダにある、 拡張子が「.mac」のファイル一覧を示します。 マクロファイルの１行目がコメント（//ではじまる行）であるなら、 それをマクロの説明だと見なして、横に表示します。

    ファイルタイプ別設定のファイルのページで指定した、 外部マクロの別パスのフォルダにあるマクロについても、 この一覧に表示されます。インクリメンタルサーチが行われる場合は、 Macroフォルダのものが優先されます。

  • マクロの編集

    選択したマクロをK2Editorで編集できます。

  • 削除ボタン

    選択したマクロをマクロファイルごと削除します。


マクロ－マクロを記述する

マクロを記述する

マクロは、直接ファイルに記述することもできます。 守らなければならないことは、マクロはMacroフォルダに入れることと、 拡張子はmacであることです。１行に一つのコマンドを書きます。

マクロファイルで、先頭が//で始まる行はコメントと見なして、 マクロ実行の際には無視します。特に、ファイルの１行目のコメントは、 マクロの説明として、 キーマクロ一覧ダイアログなどで使われます。

マクロを書くこつは、まず、雛形になるマクロを、通常のキーマクロ記録で作成して、 それをファイルに落とし、改造していくことです。

なお、使えるコマンドには、パラメータを取れるものもあります。 このヘルプのコマンド一覧に、マクロとして使えるコマンドの使用も書かれているので、 それを参考してマクロを記述してください。


マクロ－マクロの書き方－SHIFT併用コマンド

SHIFT併用コマンド

SHIFTキーを併用することで、特別な効果を持つコマンドがあります。 多くの移動コマンドは、SHIFTを併用することで、文字列選択の効果があります。

外部マクロにSHIFT併用の効果を持たせたコマンドを記述するときは、 以下のようにします。

CursorLeft, SHIFT
CursorDown, SHIFT

上記のように、カンマの次に予約語SHIFTを書きます。 これで、SHIFTキーを押しながら、そのコマンドを実行したように動作します。


マクロ－マクロの書き方－マクロ用文字列記述基準

マクロ用文字列記述基準

マクロコマンドで引数に文字列を必要とするものは、 以下の規則に準じて書いてください。

  • 基本的には、そのまま書く

    Find(ファイル,0,0,0,0,1)

  • 文字列の中でカンマが必要な場合は、文字列をダブルコーテーション（またはシングルコーテーション）で囲む

    この場合、ダブルコーテーション自体を書きたい場合は、重ねて書きます。

    Message(",を必要とする場合は、""""で囲まないとなりません")

    K2Editorのマクロ用文字列変換コマンドを使用すると、 簡単にダブルコーテーションで囲まれた文字列を作ることができます。

    ダブルコーテーションの代わりにシングルコーテーションも使えます。

なお、すべてのパラメータで文字列を使用する場合、以下の予約語が使えます。

  • %SelText%

    K2Editorで選択されている文字列

  • %CopyStr%

    クリップボードにコピーされている文字列

  • %MacroStr0%～%MacroStr9%

    共通設定－マクロのページで指定した、 マクロ文字列0～9


マクロ－マクロの書き方－マクロ用ファイル名記述基準

マクロ用ファイル名記述基準

マクロコマンド中でファイル名を記述するときは、以下の基準を守ってください。

  • マクロ用文字列記述基準を満たすこと
  • 以下の予約語が使えます
    • %Windows%

      ウィンドウズフォルダ (C:\Windowsなど)

    • %System%

      システムフォルダ(C:\Windows\Systemなど)

    • %Desktop%

      デスクトップフォルダ

    • %Temp%

      テンポラリフォルダ

    • %Personal%

      パーソナルフォルダ

    • %StartMenu%

      スタートメニュー

    • %Startup%

      スタートアップ

    • %Exec%

      K2Editor起動フォルダ

    • %Macro%

      K2Editorマクロフォルダ

    • %User%

      K2Editorユーザー設定ファイルのフォルダ

    • %OpenFileName%

      現在開いているファイル名

    • %OpenFileNameWithoutExt%

      現在開いているファイル名から拡張子をなくした文字列（.も削除します）

    • %OpenFileFolder%

      現在開いているファイルの含まれるフォルダ名。最後に\がつきます。

  • %Delimiter=[デリミタ]%コマンド以下は、\マークが[デリミタ]に変更されます

    たとえば、%Delimiter=/%%OpenFileName%とすると、 それ以降の予約語で表されたファイル・ フォルダ名の\がすべて/に置き換わります（c:\work\test.txt → C:/work/test.txt）。 %Delimiter=%とすると、デリミタがリセットされ、それ以降は置き換え動作をしません。

    %Delimiter=/%%OpenFileName% %Delimiter=%%OpenFileName%
    → c:/work/test.text c:\work\test.txt


文字コード変換

K2Editorは、Shift-JIS、JIS、EUC、 Unicode(UTF-16 LE(LittleEndian))の４種類の文字コードに対応しています。 また、CRLF、CR、LFの３種類の改行コードにも対応しています。 現在編集中のファイルの文字コードと改行コードは、 画面下部のステイタスバーに表示されています。

  • 文字コードの自動認識
  • 違う文字コードと改行コードで保存するには


文字コード変換－文字コードの自動認識

文字コードの自動認識

K2Editorは、読み込むファイルを解析して、 どの文字コードと改行コードが使われているかを識別し、 自動的にSHIFT-JIS、CRLFに変換してから読み込みます。 内部での文書の扱いは、すべてSHIFT-JIS、CRLFで行っています。

認識した文字コードと改行コードは記憶され、セーブするときには、 その文字コードと改行コードの変換してからセーブします。

あまり短いファイルだと、文字コード認識に失敗する場合があります。 その時は、文字コード変換コマンドを使用して、 文字コードを手動で変換してください。 変換した際には、認識している文字コードに注意してください。

認識している文字コードは、ウィンドウ下部のステイタスバーに表示されています。

適切な文字コードが認識されていない場合は、 「違う文字コードと改行コードで保存するには」 に従って、文字コードと改行コードを変更してください。

もとのファイルがUNICODEの場合、たぶん手動変換でも変換できません。 これは、UNICODEファイルにはヌル文字（0x00）が含まれているためで、 K2Editorでは、変換せずにヌル文字を含む文字列を扱った場合、 うまく処理することができません。
どうしても、認識に失敗するファイルがあります。 開くときに起動オプションで文字コードを指定するか、 ファイルを開くダイアログで、文字コードを指定して読み込んでください。


文字コード変換－違う文字コードと改行コードで保存するには

違う文字コードと改行コードで保存するには

編集中の文書を、SHIFT-JISやCRLF以外の文字コード・改行コードでセーブする方法は、 以下の２つの方法があります。

  • 編集中に文字コードを変更する

    保存時の文字コードと改行種類の選択コマンドを使用して、 現在編集中の文字コードと改行コードを変更することができます。 ここで変更したものは、K2Editorに記憶され、 セーブするときにその文字コードと改行コードが使われます。

  • セーブする際に、文字コードと改行コードを指定する

    名前をつけて保存コマンドで、 ファイル名をつけて保存のダイアログが表示されたとき、 ファイルの種類で文字コードと改行を指定して保存を選択します。 その後名前をつけてセーブすると、文字コードと改行種類を選択できます。


画面分割とマルチウィンドウ

K2Editorには、非常に強力な、 画面分割とマルチウィンドウ機能が登載されています。 SDI（シングルドキュメントインターフェイス）エディタで、 ここまで強力なものは他に類を見ません。

編集中のファイルの別の部分を見たいとき、 画面分割やサブウィンドウを作成すると非常に便利です。 また、いずれかのエディット画面で編集した内容は、 すべてのエディット画面に即反映されます。

エディット画面間のフォーカス移動は、 ウィンドウのフォーカス移動コマンドで行うことができます。

  • 画面の分割
  • マルチウィンドウ


画面分割とマルチウィンドウ－画面分割

画面分割

画面分割コマンドを使用すると、エディット画面を縦２つに分割できます。 それぞれのウィンドウで独立に編集操作が行えます。 また、編集した内容は、別のウィンドウに即反映されます。

分割は、現在のカーソル行で分割されます。あまり上下端に近いと、 上下を少し残して分割します。

分割線は、マウスで移動させたり、 分割境界を上・下へコマンドで移動させることができます。


画面分割とマルチウィンドウ－マルチウィンドウ

マルチウィンドウ

K2Editorは、開いているK2Editorを別のK2Editorで開くことができます。 このK2Editorをサブウィンドウ、 元のファイルを開いていたK2Editorをメインウィンドウと呼びます。 サブウィンドウはいくつでも作ることができます。

サブウィンドウは、メインウィンドウと同じプログラムです。 Windowsのタスクバーには、一つのボタンしか表示されません。

サブウィンドウを作るには、 別の編集ウィンドウコマンドを使用してください。

サブウィンドウを閉じるには、 各サブウィンドウの左上の×ボタンをクリックするか、 ALT+F4で終了してください。終了コマンドを使用すると、 メインウィンドウを終了するので、すべてのサブウィンドウを含めて終了します。

他のウィンドウは、ウィンドウメニューの一番下に表示されます。 これを選択することで、 他のサブウィンドウやメインウィンドウに移動することができます。

いずれかのウィンドウで編集した内容は、即すべてのウィンドウに反映されます。


GREP

GREPは、ファイルの中に書かれている文字列を検索語として指定し、 複数のファイルの中からその文字列を検索し、 ファイル名と、見つけた箇所の行数をK2Editorに取り込む機能です。

検索にマッチした結果は一覧になるので、 タグジャンプコマンドを使って、 そのファイルを開き、該当個所にジャンプすることができます。

GREPの実行は、常駐アイコンの右クリックメニューからもできます。 また、K2Grep.exeを起動してもできます。 K2Grep.exeのショートカットをWindowsのSendToフォルダに入れておけば、 フォルダやファイルをエクスプローラで右クリックして、 [送る]-[K2Grep.exe]とすることで、 そのフォルダやファイルをGREPの条件として取り込んでGREPを行うことができます。

K2Grep.exe本体は、必ずK2Editor.exeと同じフォルダに置いてください。

K2EditorのGREP機能では、JISやEUCの文字コードのファイルも、きちんと認識し、 GREPすることができます（こういうエディタはあんまりないんですよ、意外と）。 ただし、あまり短いファイルは変換に失敗するので、 うまく当てることができない場合があります。

GREPコマンドを実行すると、 GREPダイアログが表示されるので、 ここで検索条件や検索パスを設定し、GREPを実行することができます。 GREPが終わると、K2EditorにGREP検索結果が一覧されます。 ジャンプしたい行に移動し、 タグジャンプ（デフォルトではF10）を行ってください。

検索結果は名前をつけて保存しておくことで、後々使うこともできます。 その際、GREP用のファイルの拡張子を決めて、 ファイルタイプ別設定のGREPに設定しておくことをお勧めします。


GREP－GREPダイアログ

GREPダイアログ

GREPコマンドを起動すると、このダイアログが開きます。

  • 検索語

    検索する語句を指定します。正規表現も使えます。

    正規表現については、README.JREか、 他の文献を参考にしてください。
  • 検索対象

    検索するファイルに関する設定を行います。

    • 開いているファイル

      ここにチェックを入れると、現在K2Editorで開いているファイルに対して、 GREPを行います。

    • 検索パス

      検索するファイルを、ワイルドカードを含めて指定できます。 カレントフォルダは、ダイアログのタイトルバーに表示されます。 単独のファイルでもよいです。複数のファイルや拡張子などを指定したい場合は、 セミコロンで区切って指定します。（例：*.c;*.h） また、フォルダのフルパスを指定することもできます。 参照ボタンでフォルダを選択してください。ファイル指定がなければ、 「*.*」が指定されているものと認識します。

    • サブフォルダも検索

      指定したフォルダにフォルダがあれば、そのフォルダの中も再帰的に検索します。

    • バイナリファイルを含める

      ファイルの中にヌル文字が出てくれば、その時点で、 そのファイルをバイナリファイルとして認識します。 ここにチェックが入っていないと、その時点で、 そのファイルに対する検索を中止します。よって、 厳密には、チェックを入れていなくても、 バイナリファイルにマッチしてしまう可能性もあります。

  • 検索条件

    これに関しては、検索ダイアログと同じです。

  • 表示方式

    検索結果を表示する方法を設定するオプションです。

    • マッチした行文字列のみ

      ファイル名や行数の情報を抽出しません。 結果を編集するのが目的の場合などに便利です。

    • 相対パス

      ファイル名は通常フルパスで表示するので、非常に長くなります。 そうなると、検索情報が長くなりすぎて、見にくくなる場合があります。 このオプションを使うと、相対パスでファイル名を表示するので、 比較的短くなります。ただし、結果をセーブして後日使う場合など、 相対パスだとうまくタグジャンプできない場合がありますので、 気をつけてください。


ファイル差分

ファイル差分機能は、変更前のファイルと変更後のファイルを比べて、 その相違点を抽出する機能です。

K2EditorではGNU DIFF.EXEを呼び出して、その結果を読み込み、 行番号を色づけしたりマーカー表示することで、 ファイル差分情報を読みとります。 そのために、GNUのDIFF.EXE(ver.2.5以降）を必要とします。

GNU DIFF ver.2.5は、以下のパッケージに入っています。

rcs/diff
binaries and manual pages for the Windows NT of GNU RCS v5.6.4 & diff v2.5
http://www.vector.co.jp/soft/winnt/prog/se015009.html

NT 用と書いてありますが、32BitのWindows 用という意味です。 つまり、Win9X系でも使えます。 これをダウンロードし、 その中の DIFF.EXE を K2Editor の起動フォルダか、 パスの通ったフォルダに入れておいてください。

  • ファイル差分機能の使い方
  • diffの実行ダイアログ

最近の方は、 「パスの通ったフォルダ」という意味が分からない人がいるということを知って、 ちょっと愕然としました。 まぁ確かにDOSを使ったことのない人は意識しませんよね。 知らなくていいという人は、上記パッケージを解凍したら、 DIFF.EXEだけをK2Editorのインストールされているフォルダに入れてください。

パスとは、PATHと書いて、DOSの環境変数の一種です。DOS窓を開いて、 notepadなどと打ち込むと、どこのフォルダにいてもnotepadが立ち上がります。 これは、WindowsフォルダがPATHの中に書かれているからです。 これを「パスが通っている」といいます。

PATHを通すには、通常Cドライブ（起動ドライブ）のルートにある、 autoexec.batを編集し、SET PATH=か、PATH=と書かれている行に、 パスを通したいフォルダを追加します。複数のフォルダを書く場合は、 セミコロンで区切ります。

それが終わったら再起動します。これでパスが通りました。 DIFFを入れるフォルダを作成して、そこにPATHを通しておくと、 どこからでもDIFFを起動できます。


ファイル差分－ファイル差分機能の使い方

ファイル差分機能の使い方

ファイル差分機能を使うには、あらかじめ、パスの通ったフォルダか、 K2Editorのインストールフォルダに、 GNU DIFF ver.2.5以上が入っている必要があります。 ファイル差分の項を参照してください。

比べたいファイルを、 ２つのK2Editorで開いておくのがオーソドックスな使い方です。 その状態で、diffの実行コマンドを選択します。 diffの実行ダイアログが表示されるので、 ここで必要な設定をして、実行します。

実行には少し時間が必要です。

「diff.exeが見つかりません」というエラーメッセージが出る場合は、 パスの通ったフォルダか、K2Editorのインストールフォルダに、 diff.exeが存在しません。先に入れてください。

diffを行う場合は、テンポラリフォルダにテンポラリファイルを作成します。 大きなファイルを比較するときは、 ハードディスクの容量が十分かどうかを確認してください。

また、COMMAND.COMも必要とします。特に何も特別なことをしていないなら、 気にする必要はありません。

diffの実行が終わると、ダイアログが閉じ、 ファイル差分情報が両方のK2Editorにロードされます。 行番号を表示していない場合は、 強制的に表示する設定になります（この設定は保存されません）。

ファイル差分情報は、３種類の色分けと、２種類のマークで表示されます。

  • +記号のつく赤い行

    追加された行です。

  • -記号のつく青い行

    削除された行です。

  • !記号のつく緑の行

    変更された行です。

  • 黒い右方向三角形でマーキング

    比較されたファイルで、その行間に新たな行が追加されています。

  • 黒い左方向三角形でマーキング

    比較されたファイルで、その行間から行が削除されています。

なお、これらの色は、ファイルタイプ別設定の 色のページで変更することができます。

下・上の差分情報を探すコマンドを使用すると、 差分情報を順次見ていくことができます。比較されたK2Editorでも、 同時にスクロールされるので、横に並べておくと見やすいと思います。

比較したファイルの該当個所に移動コマンドを使用すると、 その行に差分情報がある場合、比較されたK2Editorの該当行にジャンプします。

差分情報を持ったまま編集を行うと、だんだん差分情報が狂ってくるので、 時々diffの実行を行って更新するとよいでしょう。

すべての情報が必要ではなくなったとき、 差分情報のクリアを行うと、比較されたK2Editorも含めて、 差分情報がクリアされます。


ファイル差分－diffの実行ダイアログ

diffの実行ダイアログ

このダイアログは、diffの実行コマンドを選択すると開きます。

  • 比べるファイル

    複数のK2Editorが開かれている場合は、 K2Editorで開いているファイルの一覧が表示されているので、 他のエディタで開いているファイルにチェックを入れて、 比較するファイルを選択してください。

    外部ファイルにチェックを入れ、その下にファイル名を入力すると、 K2Editorで開かれていないファイルと差分を取ることもできます。

  • 開いているファイルを...

    コマンドを実行したK2Editorで開かれているファイルを、変更後のファイルとするか、 変更前のファイルとするかを選択します。 変更すると、「追加された行」が「削除された行」になります。

  • オプション

    diff.exeに渡すオプションを指定します。

    • 大文字と小文字の違いを無視(-i)

      ファイル比較をするときに、大文字小文字が違っていても、変更されているとは認識しません。

    • ホワイトスペースの変更は無視(-b)

      空白やタブの数が変わっても、変更されているとは認識しません。 完全に削除したり、ホワイトスペースが無いところに新たに追加すると、 違うものとして認識します。

    • ホワイトスペースは無視(-w)

      ファイルを比較する際に、空白やタブは無視して比較します。 片方のファイルにホワイトスペースがなくても、違うものとは認識しません。

    • 空行は無視(-B)

      ファイル比較をする際に、空行は無視して比較します。


コマンドヘルプ

K2Editorのコマンドについて説明します。 K2Editorには、約160個のコマンドがあります。 ほとんどのコマンドをキーに割り当てて使用できます。 またマクロファイルの中に記述することができます。

  • マクロ専用コマンド
  • ファイル系コマンド
  • カーソル移動系コマンド
  • 選択・コピー系コマンド
  • 削除系コマンド
  • 挿入系コマンド
  • その他編集系コマンド
  • 検索系コマンド
  • ウィンドウ系コマンド
  • マクロ系コマンド
  • その他のコマンド


コマンド－マクロ専用コマンド

マクロ専用コマンド

マクロを記述するときにのみ使用できるコマンドです。

  • 画面描画を一時的に止める
  • 画面描画を再開する
  • メッセージ表示
  • クリップボードに文字列をコピー
  • 文字列を入力


コマンド－画面描画を一時的に止める

画面描画を一時的に止める

カテゴリ | ：マクロ専用コマンド
デフォルトのキー | ：
SHIFT併用 | ：

画面の更新を一時的にストップします。 マクロ実行中、画面更新を止めると、マクロ実行速度が速くなります。 画面の更新を再開するには、 EndUpdateを使用します。

BeginUpdate

パラメータは必要ありません。


コマンド－画面描画を再開する

画面描画を再開する

カテゴリ | ：マクロ専用コマンド
デフォルトのキー | ：
SHIFT併用 | ：

BeginUpdateで止めた画面の更新を再開します。

EndUpdate

パラメータは必要ありません。


コマンド－メッセージ表示

メッセージ表示

カテゴリ | ：マクロ専用コマンド
デフォルトのキー | ：
SHIFT併用 | ：

メッセージを表示します。パラメータで指定したメッセージを表示し、 マクロの実行を一時停止します。

Message

Message(Str)

Str ： メッセージダイアログに表示する文字列。 マクロ文字列記述基準に準拠して書くこと。

例）
Message(メッセージを出してみます)
Message(",を出す場合は、""""で囲まないとなりません")


コマンド－クリップボードに文字列をコピー

クリップボードに文字列をコピー

カテゴリ | ：マクロ専用コマンド
デフォルトのキー | ：
SHIFT併用 | ：

クリップボードに、パラメータで指定した文字列をコピーします。 空文字列を指定した場合は、クリップボードはクリアされます。

CopyStr

CopyStr(Str)

Str ： クリップボードにコピーする文字列。 マクロ用文字列記述基準に準拠しなければなりません。

例）
CopyStr(この文字列をクリップボードにコピーする)
CopyStr(",が必要な場合は「""""」で囲まなければなりません")


コマンド－文字列挿入

文字列挿入

カテゴリ | ：マクロ専用コマンド
デフォルトのキー | ：
SHIFT併用 | ：

エディタに、パラメータで指定した文字列を入力します。

InputStr

InputStr(Str)

Str ： 入力する文字列。 改行は、Enterコマンドを使用してください。 マクロ用文字列記述基準に従ってください。

例）
InputStr(これが入力される文字列です。)
InputStr(",を入力する場合は、""""で囲まないとなりません。")


コマンド－ファイル系

ファイル系コマンド

ファイルの読み書きや、K2Editorの起動・終了に関するコマンドです。

  • 新規作成
  • 開く...
  • 読み直す
  • ファイルを閉じる
  • 上書き保存
  • 名前を付けて保存...
  • カーソル位置への読み込み...
  • 印刷...
  • 保存して終了
  • 終了
  • 全保存終了
  • 全終了
  • 全保存
  • 全保存（更新ファイルのみ）
  • 破棄して終了
  • ファイル名変更...
  • 選択範囲をファイルに保存...
  • ファイルをエクスプローラで開く
  • 保存時の文字コードと改行種類の変更...


コマンド－新規作成

新規作成

カテゴリ | ：ファイル系
デフォルトのキー | ：Ctrl+N
SHIFT併用 | ：

新しいK2Editorを起動します。

NewFile

パラメータはありません。


コマンド－開く...

開く...

カテゴリ | ：ファイル系
デフォルトのキー | ：Ctrl+O
SHIFT併用 | ：

ファイルオープンダイアログを表示し、選択されたファイルを開きます。

LoadFromFile

LoadFromFile(Filename, ForceOpen, MakeFile)

パラメータがない場合は、通常のコマンド起動と同じく、 ファイルオープンダイアログを表示して開きます。

Filename | ： | 開きたいファイル（フルパス指定）。 マクロファイル名記述基準に準拠。
ForceOpen | ： | 0:普通に開く 1:マクロ実行中のK2Editorで強制的に開く 通常、他のK2Editorでそのファイルが開かれていると、 そのK2Editorにフォーカスが移ります。 しかしマクロ実行中は、 そのファイルに対してマクロでの作業をしたい場合があります。 そういう場合にForceOpen機能で強制的に開き、続くマクロを実行します。
MakeFile | ： | 0:ファイルが存在しない場合、エラーになる 1:ファイルが存在しない場合には、ファイルを作成して開く

例）
LoadFromFile(C:\Autoexec.bat)
LoadFromFile(%User%Memo.txt, 1, 1)
K2Editor のユーザーフォルダの Memo.txtを無理矢理開く。 もしファイルがない場合は、作成して開く


コマンド－読み直す

読み直す

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

編集中のファイルを読み直します。

CloseOpen

パラメータはありません。


コマンド－ファイルを閉じる

ファイルを閉じる

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

編集中のファイルを閉じます。変更状態なら、 保存するかどうかを聞いてから閉じます。

CloseFile

パラメータはありません。


コマンド－上書き保存

上書き保存

カテゴリ | ：ファイル系
デフォルトのキー | ：Ctrl+S
SHIFT併用 | ：

編集中のファイルを上書き保存します。新規に編集したファイルの場合は、 名前をつけて保存と同じになります。

SaveFile

パラメータはありません。


コマンド－名前を付けて保存...

名前を付けて保存...

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

セーブダイアログを表示し、ファイル名の入力を求めてから、 ファイルを保存します。

SaveAs

SaveAs(Filename, CharCode, ReturnCode)
パラメータ指定がない場合は、セーブダイアログを表示して保存します。

Filename | ： | 保存するファイル名。フルパスで指定する。 \Q の場合は保存ファイルを問い合わせる。 \F の場合は、現在のファイル名で保存する。現在のファ イル名がない場合は、保存ファイルを問い合わせる。 その他は、 マクロ用ファイル名記述基準に準拠する。
CharCode | ： | 文字コード指定 0:SHIFT-JIS 1:JIS 2:EUC 3:UNICODE
ReturnCode | ： | 改行コード指定 0:CRLF 1:CR 2:LF

例）
SaveAs(D:\TEMP\TEMP.TXT)
SJIS, CRLFで指定ファイルに保存

SaveAs(\Q, 1, 2)
JIS, LF で保存。ファイル名は指定する。

SaveAs(\F, 2, 0)
EUC, CRLF に変換して、上書き保存する。


コマンド－カーソル位置への読み込み...

カーソル位置への読み込み...

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

オープンダイアログを表示し、入力されたファイル名の内容を、 カーソル位置に挿入します。

ReadFileToCaret

ReadFileToCaret(Filename)
パラメータがないと、オープンダイアログを表示します。

Filename ： 開きたいファイル（フルパス指定）。 なお、マクロ用ファイル名記述基準に準拠します。

例）
ReadFileToCaret(C:\Autoexec.bat)


コマンド－印刷...

印刷...

カテゴリ | ：ファイル系
デフォルトのキー | ：Ctrl+P
SHIFT併用 | ：

印刷ダイアログを表示して、印刷を行います。 印刷ダイアログからはプレビュー表示もできます。

Print

パラメータはありません。


コマンド－保存して終了

保存して終了

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

上書き保存後、終了します。ファイル名が無題の場合は、セーブダイアログを開いて、 ファイル名を入力するように求めます。

SaveClose

パラメータはありません。


コマンド－終了

終了

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

終了します。変更状態なら、セーブするかどうかを尋ねます。

Close

パラメータはありません。


コマンド－全保存終了

全保存終了

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

すべてのK2Editorについて、上書き保存して終了します。 ファイル名がない場合は、セーブダイアログを開いて、 ファイル名を入力するように求めます。

AllSaveClose

パラメータはありません。


コマンド－全終了

全終了

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

すべてのK2Editorを終了します。変更状態なら、 セーブするかどうかを尋ねます。

AllClose

パラメータはありません。


コマンド－全保存

全保存

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

すべてのK2Editorに対して、上書き保存を行います。ファイル名が無題の場合は、 セーブダイアログを開いて、ファイル名を入力するように求めます。

AllSave

パラメータはありません。


コマンド－全保存（更新ファイルのみ）

全保存（更新ファイルのみ）

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

すべてのK2Editorで、変更されている場合、上書き保存します。 ファイル名が無題の場合は、セーブダイアログを表示して、 ファイル名を入力するように求めます。

AllSaveOnlyModified

パラメータはありません。


コマンド－破棄して終了

破棄して終了

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

ファイルが変更状態でも、破棄して終了します。

Destroy

パラメータはありません。


コマンド－ファイル名変更...

ファイル名変更...

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

編集中の文書のファイル名を変更します。ダイアログを出して、 ファイル名を入力するように求めます。

EditFilename

パラメータはありません。


コマンド－選択範囲をファイルに保存...

選択範囲をファイルに保存...

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

選択範囲をファイルに保存します。セーブダイアログを表示して、 ファイル名を入力するように求めます。

SaveSelectedToFile

SaveSelectedToFile(Filename, AppendMode, CharCode, ReturnCode)

Filename | ： | 保存するファイル名。フルパスで指定する。 \Q の場合は保存ファイルを問い合わせる。 マクロ用ファイル名記述基準に従う。
AppendMode | ： | 上書きするか、既にあるファイルに追加するかどうかを設定する。 0: 上書き 1: 追加
CharCode | ： | 文字コード指定 0:SHIFT-JIS 1:JIS 2:EUC 3:UNICODE
ReturnCode | ： | 改行コード指定 0:CRLF 1:CR 2:LF


コマンド－ファイルをエクスプローラで開く

ファイルをエクスプローラで開く

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

エクスプローラを詳細表示で開き、編集中のファイルを選択します。

OpenExplorer

パラメータはありません。


コマンド－保存時の文字コードと改行種類の変更...

保存時の文字コードと改行種類の変更...

カテゴリ | ：ファイル系
デフォルトのキー | ：
SHIFT併用 | ：

次に保存するときの、 文字コードと改行コードをあらかじめ指定します。 コマンドを選択すると、 文字コードと改行コードを選択するダイアログが表示されます。 必要な設定をしてOKボタンを押せば、スタイタスバー上の表示が変更されます。 次に保存したとき、文字コードと改行コードを変換して保存します。

ChangeOpenFileCode

パラメータはありません。


コマンド－カーソル移動系

カーソル移動系コマンド

カーソル移動に関するコマンドです。

  • カーソル上
  • カーソル下
  • カーソル右
  • カーソル左
  • 単語右
  • 単語左
  • 行頭に移動
  • 行末に移動
  • 物理行頭に移動
  • 物理行末に移動
  • ファイルの先頭に移動
  • ファイルの最後に移動
  • 次ページ
  • 前ページ
  • 画面の先頭に移動
  • 画面の最後に移動
  • 最後に編集した所に移動
  • 指定行に移動...
  • 現在行のマーク／マーク解除
  • マーク一覧...
  • マーク行の下検索
  • マーク行の上検索
  • マークをすべて解除
  • マーク1～0を設定
  • マーク1～0に移動
  • 下に行スクロール
  • 上に行スクロール


コマンド－カーソル上

カーソル上

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Up
SHIFT併用 | ：選択

カーソルを一つ上に移動します。カラムは、ある程度保存されるので、 行末にいる場合は、行末をトレースします。

CursorUp

パラメータはありません。


コマンド－カーソル下

カーソル下

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Down
SHIFT併用 | ：選択

カーソルを一つ下に移動します。 カラムはある程度保存されるので、行末にいる場合は、行末をトレースします。

CursorDown

パラメータはありません。


コマンド－カーソル右

カーソル右

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Right
SHIFT併用 | ：選択

カーソルを一つ右に移動します。

物理行末にいる場合、 共通設定の一般設定のページで、 「行末<->行頭」カーソル移動を禁止していなければ、 次行の行頭に移動します。

CursorRight

パラメータはありません。


コマンド－カーソル左

カーソル左

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Left
SHIFT併用 | ：選択

カーソルを一つ左に移動します。

物理行頭にいる場合、 共通設定の一般設定のページで、 「行末<->行頭」カーソル移動を禁止していなければ、 前行のの行末に移動します。

CursorLeft

パラメータはありません。


コマンド－単語右

単語右

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+Right
SHIFT併用 | ：選択

カーソルを単語単位で一つ右に移動します。

物理行末にいる場合、 共通設定の一般設定のページで、 「行末<->行頭」カーソル移動を禁止していなければ、 次行の行頭に移動します。

WordRight

パラメータはありません。


コマンド－単語左

単語左

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+Left
SHIFT併用 | ：選択

カーソルを単語単位で一つ左に移動します。

物理行頭にいる場合、 共通設定の一般設定のページで、 「行末<->行頭」カーソル移動を禁止していなければ、 前行のの行末に移動します。

WordLeft

パラメータはありません。


コマンド－行頭に移動

行頭に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Home
SHIFT併用 | ：選択

カーソルを、論理行頭に移動します。

MoveLineStart

パラメータはありません。


コマンド－行末に移動

行末に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：End
SHIFT併用 | ：選択

カーソルを論理行末に移動します。

長い行を折り返しているとき、 論理行末は、その折り返し行の行末文字の一つ手前になります。

MoveLineEnd

パラメータはありません。


コマンド－物理行頭に移動

物理行頭に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：選択

物理行頭に移動します。

長い行を折り返していないとき、このコマンドと、 行頭に移動コマンドは同じ操作になります。

MovePhysicalLineStart

パラメータはありません。


コマンド－物理行末に移動

物理行末に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：選択

物理行末に移動します。

長い行を折り返していないとき、このコマンドと、 行末に移動コマンドは同じ操作になります。

MovePhysicalLineEnd

パラメータはありません。


コマンド－ファイルの先頭に移動

ファイルの先頭に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+Home
SHIFT併用 | ：選択

カーソルを文書の先頭に移動します。

MoveFileStart

パラメータはありません。


コマンド－ファイルの最後に移動

ファイルの最後に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+End
SHIFT併用 | ：選択

カーソルを文書の最後（EOFの手前）に移動します。

MoveFileEnd

パラメータはありません。


コマンド－次ページ

次ページ

カテゴリ | ：カーソル移動系
デフォルトのキー | ：PgDn
SHIFT併用 | ：選択

次ページにスクロールします。 ページダウン、スクロールアップと呼ばれます。

NextPage

パラメータはありません。


コマンド－前ページ

前ページ

カテゴリ | ：カーソル移動系
デフォルトのキー | ：PgUp
SHIFT併用 | ：選択

前ページにスクロールします。 ページアップ、スクロールダウンと呼ばれます。

PrevPage

パラメータはありません。


コマンド－画面の先頭に移動

画面の先頭に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：選択

現在の編集ウィンドウをスクロールせず、 編集ウィンドウの最初にカーソルを移動します。

MoveWindowStart

パラメータはありません。


コマンド－画面の最後に移動

画面の最後に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：選択

現在の編集ウィンドウをスクロールせず、 ウィンドウの最後にカーソルを移動します。

MoveWindowEnd

パラメータはありません。


コマンド－最後に編集した所に移動

最後に編集した所に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：選択

最後に編集した位置に、カーソルを移動します。

JumpPrevModifiedPos

パラメータはありません。


コマンド－指定行に移動...

指定行に移動...

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+J
SHIFT併用 | ：選択

指定された行にジャンプします。 このコマンドを選択すると行番号の入力が求められます。

コマンドを選択するときにSHIFTキーを押していると、 現在のカーソル位置からジャンプした行まで、選択を行います。

JumpRow

JumpRow(Row)
パラメータがない場合は、行番号の入力を求めます。

Row ： ジャンプする行を指定します。

例）
JumpRow(10)


コマンド－現在行のマーク／マーク解除

現在行のマーク／マーク解除

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+M
SHIFT併用 | ：

現在カーソルがある行に、通常マークをつけます。 その行に通常マークまたは番号付きマークがある場合は、 そのマークを消します。

EOFだけの行には、マークをつけることはできません。

ToggleMark

ToggleMark(sw)
パラメータがない場合は、トグル動作

sw ： 0: マークをクリア
1: マークをつける

例）
ToggleMark(1)－現在行にマークをセット


コマンド－マーク一覧...

マーク一覧...

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Shift+Ctrl+M
SHIFT併用 | ：

マーク一覧ダイアログを表示します。

ShowMarkList

パラメータはありません。


コマンド－マーク行の下検索

マーク行の下検索

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+Down
SHIFT併用 | ：選択

カーソル行よりも下のマーク行にジャンプします。

通常マーク・番号付きマークに関わらず、検索します。

FindUnderMark

パラメータはありません。


コマンド－マーク行の上検索

マーク行の上検索

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+Up
SHIFT併用 | ：選択

カーソル行よりも上のマーク行にジャンプします。

通常マーク・番号付きマークに関わらず、検索します。

FindOverMark

パラメータはありません。


コマンド－マークをすべて解除

マークをすべて解除

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：

通常マーク・番号付きマーク共、すべてのマークを削除します。

ClearAllMark

ClearAllMark(sw)
パラメータがないときは、全マーククリア

sw ： 0: 全マーククリア
1: 通常マークのみ
2: 番号付きマークのみ


コマンド－マーク0～9を設定

マーク0～9を設定

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Shift+Ctrl+0～9
SHIFT併用 | ：

現在カーソルのある行に、番号付きマークをつけます。

指定番号のマークが他の行にあるときは、そのマークは削除され、 現在行にマークされます。

現在行に何らかのマークがあるときは、そのマークが削除され、 指定番号のマークがつきます。

現在行に指定番号マークがある場合は、そのマークを消します。

SetMarkX (X: 0-9)

SetMarkX(sw)
パラメータがない場合は、通常動作

sw ： 0: その番号付きマークをクリア
1: その行に番号付きマークをセット


コマンド－マーク0～9に移動

マーク0～9に移動

カテゴリ | ：カーソル移動系
デフォルトのキー | ：Ctrl+0～9
SHIFT併用 | ：選択

指定された番号付きマーク行に移動します。

JumpMarkX

パラメータはありません。


コマンド－下に行スクロール

下に行スクロール

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：

カーソルを移動しないで、下に１行スクロールします。

カーソルがエディットウィンドウ内からはずれるとき、 共通設定の一般設定のページで、 「縦スクロールバーを使ってもカーソル位置はそのまま」にチェックが入っていないと、 カーソル位置はウィンドウ端で固定されます。

LineDown

パラメータはありません。


コマンド－上に行スクロール

上に行スクロール

カテゴリ | ：カーソル移動系
デフォルトのキー | ：
SHIFT併用 | ：

カーソルを移動しないで、上に１行スクロールします。

カーソルがエディットウィンドウ内からはずれるとき、 共通設定の一般設定のページで、 「縦スクロールバーを使ってもカーソル位置はそのまま」にチェックが入っていないと、 カーソル位置はウィンドウ端で固定されます。

LineUp

パラメータはありません。


コマンド－選択・コピー系

選択・コピー系コマンド

選択したりクリップボード関連のコマンドです。

  • すべてを選択
  • コピー
  • 引用付きコピー
  • 貼り付け
  • 切り抜き
  • 単語選択
  • 行の選択
  • 単語をコピー
  • 行をコピー
  • 引用付き貼り付け
  • 開いているファイル名をコピー
  • 箱形選択


コマンド－すべてを選択

すべてを選択

カテゴリ | ：選択・コピー
デフォルトのキー | ：Ctrl+A
SHIFT併用 | ：

エディタ内の文字列をすべて選択します。

SelectAll

パラメータはありません。


コマンド－コピー

コピー

カテゴリ | ：選択・コピー
デフォルトのキー | ：Ctrl+C
SHIFT併用 | ：

選択されている文字を、クリップボードにコピーします。

Copy

パラメータはありません。


コマンド－引用付きコピー

引用付きコピー

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：

選択されている文字を、クリップボードにコピーします。 その際、行頭に、引用符を付加します。

引用符は、共通設定の一般設定のページ で行います。

InyouCopy

パラメータはありません。


コマンド－貼り付け

貼り付け

カテゴリ | ：選択・コピー
デフォルトのキー | ：Ctrl+V
SHIFT併用 | ：

クリップボードの文字列を、カーソル位置に挿入します。 選択されている文字列がある場合は、その文字列を削除した後、挿入します。

Paste

パラメータはありません。


コマンド－切り抜き

切り抜き

カテゴリ | ：選択・コピー
デフォルトのキー | ：Ctrl+X
SHIFT併用 | ：

選択されている文字列をクリップボードにコピーし、 その後選択文字列を削除します。

Cut

パラメータはありません。


コマンド－単語選択

単語選択

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：

カーソル位置の単語を選択します。

SelectWord

パラメータはありません。


コマンド－行の選択

行の選択

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：

カーソルのある物理行を選択します。

SelectLine

パラメータはありません。


コマンド－単語をコピー

単語をコピー

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：

カーソル部分の単語を、クリップボードにコピーします。

CopyWord

パラメータはありません。


コマンド－行をコピー

行をコピー

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：

カーソルのある物理行を、クリップボードにコピーします。

CopyLine

パラメータはありません。


コマンド－引用付き貼り付け

引用付き貼り付け

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：

貼り付けを行いますが、 その際に、引用符を各行頭に付加します。

引用符は、共通設定の一般設定のページ で行います。

InyouPaste

パラメータはありません。


コマンド－開いているファイル名をコピー

開いているファイル名をコピー

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：ファイル名のみコピー（パスを除く）

開いているファイル名をクリップボードにコピーします。 SHIFTを押しながらコマンドを選択すると、 ファイル名のみコピーし、パスは除きます。

OpenFilenameCopy

OpenFilenameCopy(FilenameOnly)

FilenameOnly ： 0: フルパス
1: ファイル名のみ（パスを除く）

例）
OpenFilenameCopy(1)－ファイル名のみコピー


コマンド－箱形選択

箱形選択

カテゴリ | ：選択・コピー
デフォルトのキー | ：
SHIFT併用 | ：

箱形選択モードに入ります。

箱形選択モードに入ると、その後選択をすると箱形選択できます。 カーソルは、一時フリーカーソルモードになります。 箱形選択モードかどうかは、ステイタスバーに表示されます。

箱形選択を行った後、選択範囲が解除されると、通常選択モードに戻ります。

なお、箱形選択モード時にこのコマンドを使用すると、 通常選択モードに戻ります。

箱形選択モードでも、SHIFTを押しながら普通に選択します。 マウスを使うときは、ALTキーを押しながら選択することで、箱形選択になります。

箱形選択してクリップボードにコピーしたものをK2Editorに貼り付けると、 貼り付け位置にある文字列を右に押しやりながら、挿入されます。 貼り付けた後、何が起こったかわからなくなる場合があるので、 何度か練習して、慣れるようにしましょう。

BoxSelection

パラメータはありません。


コマンド－削除系

削除系コマンド

削除を行うコマンドです。

  • 削除
  • 行削除
  • カーソルより後ろを削除
  • カーソルより前を削除
  • 単語削除
  • バックスペース


コマンド－削除

削除

カテゴリ | ：削除系
デフォルトのキー | ：Del
SHIFT併用 | ：

削除動作を行います。

選択されている場合は、選択文字列を削除します。 選択されていない場合は、カーソル位置の文字を、一文字削除します。

Delete

パラメータはありません。


コマンド－行削除

行削除

カテゴリ | ：削除系
デフォルトのキー | ：
SHIFT併用 | ：

カーソルのある物理行を削除します。

DeleteLine

パラメータはありません。


コマンド－カーソルより後ろを削除

カーソルより後ろを削除

カテゴリ | ：削除系
デフォルトのキー | ：
SHIFT併用 | ：

物理行のカーソルより後ろを削除します。

DeleteLineEnd

パラメータはありません。


コマンド－カーソルより前を削除

カーソルより前を削除

カテゴリ | ：削除系
デフォルトのキー | ：
SHIFT併用 | ：

物理行の、カーソルより前を削除します。

DeleteLineStart

パラメータはありません。


コマンド－単語削除

単語削除

カテゴリ | ：削除系
デフォルトのキー | ：
SHIFT併用 | ：

カーソル位置の単語を削除します。

DeleteWord

パラメータはありません。


コマンド－バックスペース

バックスペース

カテゴリ | ：削除系
デフォルトのキー | ：BkSp
SHIFT併用 | ：

バックスペースを行います。文字列が選択されているときは、 選択文字列を削除します。選択されていないときは、 カーソルの一つ前の文字を削除します。

BackSpace

パラメータはありません。


コマンド－挿入系

挿入系コマンド

文字列の挿入系のコマンドです。

  • 改行
  • タブ
  • 空行挿入


コマンド－改行

改行

カテゴリ | ：挿入系
デフォルトのキー | ：Enter
SHIFT併用 | ：

カーソル位置に改行を挿入します。

Enter

パラメータはありません。


コマンド－タブ

タブ

カテゴリ | ：挿入系
デフォルトのキー | ：
SHIFT併用 | ：

カーソル位置にタブ文字を挿入します。 デフォルトでTABキーは、 インデントにわりつけられています。

Tab

パラメータはありません。


コマンド－空行挿入

空行挿入

カテゴリ | ：挿入系
デフォルトのキー | ：
SHIFT併用 | ：

カーソルのある行の手前に、空行を挿入します。

InsertEmptyLine

パラメータはありません。


コマンド－その他編集系

その他編集系コマンド

編集関連のその他のコマンドです。

  • やり直し
  • やり直しのやり直し
  • 大文字<->小文字の変換
  • 大文字に変換
  • 小文字に変換
  • TAB->空白変換
  • 空白->TAB変換
  • インデント
  • 逆インデント
  • 整形
  • 行の分割
  • センタリング
  • 左寄せ
  • 右寄せ


コマンド－やり直し

やり直し

カテゴリ | ：その他編集
デフォルトのキー | ：Ctrl+Z
SHIFT併用 | ：

やり直し（アンドゥ）を行います。

やり直しできる回数は、 共通設定の一般設定のページ で設定できます。

セーブしたところまでやり直しをすると、変更状態が解除されます。 それ以上やり直しを行うと、再び変更状態になります。

Undo

パラメータはありません。


コマンド－やり直しのやり直し

やり直しのやり直し

カテゴリ | ：その他編集
デフォルトのキー | ：Shift+Ctrl+Z
SHIFT併用 | ：

やり直しのやり直し（リドゥ）を行います。

アンドゥとリドゥを使って、前に保存した状態に戻すと、 編集しているファイルの変更状態が解除されます。

Redo

パラメータはありません。


コマンド－大文字

大文字<->小文字の変換

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

選択されている文字列のうち、半角文字の大文字と小文字を変換します。 全角文字には作用しません。

ExchangeUpperLower

パラメータはありません。


コマンド－大文字に変換

大文字に変換

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

選択されている文字列のうち、半角文字を大文字に変換します。 全角文字には作用しません。

ChangeUpperCase

パラメータはありません。


コマンド－小文字に変換

小文字に変換

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

選択されている文字列のうち、半角文字を小文字に変換します。 全角文字には作用しません。

ChangeLowerCase

パラメータはありません。


コマンド－TAB->空白変換

TAB->空白変換

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

カーソルのある行や、選択されている行にあるタブを、空白に置き換えます。 行の一部だけ選択されていても、行単位で選択範囲が拡張されます

TabToSpace

パラメータはありません。


コマンド－空白->TAB変換

空白->TAB変換

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

カーソルのある行や、選択されている行の空白を、できるだけタブで置き換えます。 置き換えられないところは空白が残ります。行の一部が選択されている場合、 行が選択されていると見なします。

SpaceToTab

パラメータはありません。


コマンド－インデント

インデント

カテゴリ | ：その他編集
デフォルトのキー | ：Tab
SHIFT併用 | ：

選択されていない場合、カーソル位置にタブを挿入します。 選択されている場合、選択範囲の行の行頭にインデントを挿入します。

インデント幅は、ファイルタイプ別設定の 入力と移動のページで設定すれば、 タブとは別に設定できます。

InsertIndent

パラメータはありません。


コマンド－逆インデント

逆インデント

カテゴリ | ：その他編集
デフォルトのキー | ：Shift+Tab
SHIFT併用 | ：

選択されている行の行頭にタブかスペースがある場合、設定されたタブ文字数分、 取り除きます。タブ文字数に足りない場合は、すべて削除します。

ReverseIndent

パラメータはありません。


コマンド－整形

整形

カテゴリ | ：その他編集
デフォルトのキー | ：Shift+Enter
SHIFT併用 | ：

整形を行います。 詳しくは、ヘルプの整形を見てください。

Seikei

パラメータはありません。


コマンド－行の分割

行の分割

カテゴリ | ：その他編集
デフォルトのキー | ：Ctrl+Enter
SHIFT併用 | ：

行の分割を行います。 詳しくは、ヘルプの整形を見てください。

DivideLine

パラメータはありません。


コマンド－センタリング

センタリング

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

選択されていない場合はカーソルの行を、選択されている場合は、 選択されている行すべてについて、センタリングを行います。

ファイルタイプ別設定の入力・移動のページ で設定される、整形桁数に対してセンタリングされます。

CenterAlign

パラメータはありません。


コマンド－左寄せ

左寄せ

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

選択されていない場合はカーソルの行を、選択されている場合は、 選択されている行すべてについて、左寄せを行います。

LeftAlign

パラメータはありません。


コマンド－右寄せ

右寄せ

カテゴリ | ：その他編集
デフォルトのキー | ：
SHIFT併用 | ：

選択されていない場合はカーソルの行を、選択されている場合は、 選択されている行すべてについて、右寄せを行います。

ファイルタイプ別設定の入力・移動のページ で設定される、整形桁数に対して右寄せされます。

RightAlign

パラメータはありません。


コマンド－検索系

検索系コマンド

検索・置換・GREP・ファイル差分などのコマンドです。

  • 検索...
  • 下候補
  • 上候補
  • 検索開始位置へ戻る
  • 置換...
  • 対応する括弧を探す
  • GREP...
  • 検索文字のクリア
  • diffの実行...
  • 差分情報の下検索
  • 差分情報の上検索
  • 差分情報のクリア
  • 比較したファイルの該当個所へ移動


コマンド－検索...

検索...

カテゴリ | ：検索系
デフォルトのキー | ：Ctrl+F
SHIFT併用 | ：

検索を行います。 詳しくは、ヘルプの検索と置換を参照してください。

Find

Find(FindStr, Case, Word, RegularExp, Fuzz, PostProcess)
パラメータがないと、検索ダイアログを表示する。

FindStr | ： | 検索語を指定。 マクロ文字列記述基準に準拠して書くこと。
Case | ： | 大文字小文字の区別 0: 区別しない 1: 区別する
Word | ： | 単語検索 0: 単語検索しない 1: 単語検索する
RegularExp | ： | 正規表現 0: 正規表現は使わない 1: 正規表現を使う
Fuzz | ： | 曖昧検索。全角と半角文字の両方にマッチする 0: 使わない 1: 使う
PostProcess | ： | 検索設定の後、 0: 何もしない 1: 直後に下検索をする 2: 直後に上検索をする

例）
Find("^(Function|FUNCTION)", 0, 0, 1, 0, 1)


コマンド－下候補

下候補

カテゴリ | ：検索系
デフォルトのキー | ：F3
SHIFT併用 | ：

前に設定された条件で、下検索を行います。

FindDown

パラメータはありません。


コマンド－上候補

上候補

カテゴリ | ：検索系
デフォルトのキー | ：Shift+F3
SHIFT併用 | ：

前に設定された条件で、上検索を行います。

FindUp

パラメータはありません。


コマンド－検索開始位置へ戻る

検索開始位置へ戻る

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：選択

直前に検索をはじめた位置にカーソルを移動します。

FindComeback

パラメータはありません。


コマンド－置換...

置換...

カテゴリ | ：検索系
デフォルトのキー | ：Ctrl+R
SHIFT併用 | ：

置換を行います。 詳しくは、ヘルプの検索と置換を参照してください。

Replace

Replace(FindStr, ReplaceStr, Case, Word, RegularExp, Fuzz, PostProcess)

FindStr | ： | 検索語を指定。 マクロ文字列記述基準に準拠して書くこと。
FindStr | ： | 置換語を指定。 マクロ文字列記述基準に準拠して書くこと。
Case | ： | 大文字小文字の区別 0: 区別しない 1: 区別する
Word | ： | 単語検索 0: 単語検索しない 1: 単語検索する
RegularExp | ： | 正規表現 0: 正規表現は使わない 1: 正規表現を使う
Fuzz | ： | 曖昧検索。全角と半角文字の両方にマッチする 0: 使わない 1: 使う
PostProcess | ： | 検索設定の後、 0: 何もしない 1: 直後に下検索をする 2: 直後に上検索をする 3: 連続置換 4: すべて置換

例）
Replace("^(Function|FUNCTION)", "Procedure", 0, 0, 1, 0, 1)


コマンド－対応する括弧を探す

対応する括弧を探す

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：効果あり

カーソルのある位置の括弧に対応する括弧にジャンプします。 間にコメントセット文字列や、 これ以降の文字列をコメントとする文字列で、 コメントアウトされている括弧がある場合は、 その括弧は計算に入れません。

対応している括弧は、()、{}、[]、<>です。 また、pascalで使用する(begin|try|case)、end対にも対応しています。

SearchBracket

パラメータはありません。


コマンド－GREP

GREP

カテゴリ | ：検索系
デフォルトのキー | ：Ctrl+G
SHIFT併用 | ：

GREPを行います。 詳しくは、ヘルプのGREPを参照してください。

Grep

Grep(FindStr, Path, SubFolder, Case, Word, RegularExp, Fuzz, EnBin)

FindStr | ： | 検索語を指定。 マクロ文字列記述基準に準拠して書くこと。
Path | ： | 検索パスを指定。 マクロ用ファイル名記述基準に準拠して書くこと。
SubFolder | ： | サブフォルダを検索に含めるか。 0: 含めない 1: 含める
Case | ： | 大文字小文字の区別 0: 区別しない 1: 区別する
Word | ： | 単語検索 0: 単語検索しない 1: 単語検索する
RegularExp | ： | 正規表現 0: 正規表現は使わない 1: 正規表現を使う
Fuzz | ： | 曖昧検索。全角と半角文字の両方にマッチする 0: 使わない 1: 使う
EnBin | ： | バイナリファイルを検索するか 0: 検索しない 1: 検索する

例）
Grep("^(Function|FUNCTION)","C:\Source\*.pas;*.txt",1, 0, 1, 1, 0, 0)


コマンド－検索文字のクリア

検索文字のクリア

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：

検索条件をクリアして、検索文字の色つけなども解除します。

ClearFindItem

パラメータはありません。


コマンド－diffの実行

diffの実行

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：

diffを実行してファイル差分情報を取得します。 詳しくは、ヘルプのファイル差分を参照してください。

DiffExec

パラメータはありません。


コマンド－差分情報の下検索

差分情報の下検索

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：

diffの実行でファイル差分情報を取得後、 下のファイル差分情報がある行を検索し、ジャンプします。 比較したファイルがK2Editorで開かれている場合、 そのK2Editorも該当行にスクロールします。

FindUnderDiff

パラメータはありません。


コマンド－差分情報の上検索

差分情報の上検索

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：

diffの実行でファイル差分情報を取得後、 上のファイル差分情報がある行を検索し、ジャンプします。 比較したファイルがK2Editorで開かれている場合、 そのK2Editorも該当行にスクロールします。

FindOverDiff

パラメータはありません。


コマンド－差分情報のクリア

差分情報のクリア

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：

diffの実行でファイル差分情報を取得後、 差分情報をクリアします。diffを実行する前に、行番号表示していなかった場合は、 元に戻ります。また、比較したファイルがK2Editorで開かれているとき、 そのK2Editorの差分情報もクリアします。

ClearDiffInfo

パラメータはありません。


コマンド－比較したファイルの該当個所へ移動

比較したファイルの該当個所へ移動

カテゴリ | ：検索系
デフォルトのキー | ：
SHIFT併用 | ：

diffの実行でファイル差分情報を取得後、 もし比較したファイルが他のK2Editorで開かれているなら、 現在の行のファイル比較情報に対応する、 比較されたファイルの行にジャンプします。

比較されたファイルがK2Editorで開かれてなかったり、 カーソル行に比較情報がない場合は、何も起こりません。

ChangeDiffFocus

パラメータはありません。


コマンド－ウィンドウ系

ウィンドウ系コマンド

並び替えや、分割、フォーカス系のコマンドです。

  • 縦に並べる
  • 横に並べる
  • 重ねて表示
  • 並べて表示
  • 全部最小化
  • 縦方向に最大化
  • 次のウィンドウ
  • 前のウィンドウ
  • 画面分割
  • ウィンドウのフォーカス移動
  • 分割境界を上へ
  • 分割境界を下へ
  • 別の編集ウィンドウ作成


コマンド－縦に並べる

縦に並べる

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

開いているK2Editorのうち、最小化されていないものを、 縦に並べます。

VerticalLineup

パラメータはありません。


コマンド－横に並べる

横に並べる

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

開かれているK2Editorのうち、最小化されていないものを、 横に並べます。

HorizotalLineup

パラメータはありません。


コマンド－重ねて表示

重ねて表示

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

開かれているK2Editorのうち、最小化されていないものを、 重ねて並べます。

Pile

パラメータはありません。


コマンド－並べて表示

並べて表示

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

開かれているK2Editorのうち、最小化されていないものを、 格子状に並べます。

LineupOrder

パラメータはありません。


コマンド－全部最小化

全部最小化

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

開いているK2Editorをすべて最小化します。

AllMinimize

パラメータはありません。


コマンド－縦方向に最大化

縦方向に最大化

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

編集中のK2Editorの幅は保ったまま、最大化します。

最大化した後、ウィンドウが動かせますが、そういう仕様です。 また、最大化ボタンをもう一度押して通常の大きさに戻した後、 再度最大化ボタンを押すと、縦方向に最大化します。 それを解除するには、もう一度、縦方向に最大化コマンドを選択して、 チェックをはずしてください。

MaximizeVertical

パラメータはありません。


コマンド－次のウィンドウ

次のウィンドウ

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

起動しているK2Editorのうち、次のK2Editorにフォーカスを与えます。 最小化しているものにはフォーカスは移りません。

対象のK2Editorがサブウィンドウを持っている場合、 メインウィンドウのみにフォーカスが移ります。

NextEditor

パラメータはありません。


コマンド－前のウィンドウ

前のウィンドウ

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

起動しているK2Editorのうち、前のK2Editorにフォーカスを与えます。 最小化しているものにはフォーカスは移りません。

対象のK2Editorがサブウィンドウを持っている場合、 メインウィンドウのみにフォーカスが移ります。

PrevEditor

パラメータはありません。


コマンド－画面分割

画面分割

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：F5
SHIFT併用 | ：

K2Editorの編集画面を、２つに分割します。分割線はマウスで動かすか、 分割線を上へ・ 分割線を下へコマンドを使用して動かせます。

各編集ウィンドウでの変更は、即他の編集ウィンドウへ反映されます。

サブウィンドウも含めたウィンドウ間のフォーカス移動は、 ウィンドウのフォーカス移動 コマンドを使用して行います。

DivideWindow

パラメータはありません。


コマンド－ウィンドウのフォーカス移動

ウィンドウのフォーカス移動

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：Ctrl+W
SHIFT併用 | ：効果あり

サブウィンドウや、ウィンドウ分割したウィンドウ間を、 順番にフォーカス移動します。SHIFTを押しながらコマンドを選択すると、 反対周りになります。

ToggleWindowFocus

ToggleWindowFocus(sw)
パラメータがない場合は、sw=0と同じ

sw ： 0: 順方向（分割ウィンドウの場合、上から下）
1: 逆方向（分割ウィンドウの場合、下から上）

例）
ToggleWindowFocus(1)


コマンド－分割境界を上へ

分割境界を上へ

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

画面分割コマンドで、 ウィンドウを分割しているとき、分割線を１行分上に移動します。

SplitterUp

パラメータはありません。


コマンド－分割境界を下へ

分割境界を下へ

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

画面分割コマンドで、 ウィンドウを分割しているとき、分割線を１行分下に移動します。

SplitterDown

パラメータはありません。


コマンド－別の編集ウィンドウ作成

別の編集ウィンドウ作成

カテゴリ | ：ウィンドウ系
デフォルトのキー | ：
SHIFT併用 | ：

別の編集ウィンドウ（サブウィンドウ）を作成します。 詳しくは、ヘルプのマルチウィンドウを 参照してください。

NewWindow

パラメータはありません。


コマンド－マクロ系

マクロ系コマンド

キーマクロ関連のコマンドです。 マクロコマンドとして使う場合、動作の保証はできないので、使わないでください。

  • 記録開始／記録終了
  • 再生
  • 記録の保存...
  • 外部マクロ読み込み...
  • 外部マクロ実行...
  • マクロ1～10の実行
  • マクロ用文字列変換
  • カーソル位置直前のマクロを実行


コマンド－記録開始／記録終了

記録開始／記録終了

カテゴリ | ：マクロ系
デフォルトのキー | ：Shift+F1
SHIFT併用 | ：

キーマクロの記録開始と記録終了をトグルします。 詳しくは、 ヘルプのマクロを参照してください。

ToggleMacroRecord

パラメータなし（マクロ内での動作保証はしません）


コマンド－再生

再生

カテゴリ | ：マクロ系
デフォルトのキー | ：Shift+F2
SHIFT併用 | ：

記録開始／記録終了 コマンドで記録したマクロを再生します。 外部マクロ読み込み... コマンドで読み込んだマクロを実行するときも、このコマンドを使います。

ReplayMacro

パラメータなし（マクロ内での動作保証はしません）


コマンド－記録の保存...

記録の保存...

カテゴリ | ：マクロ系
デフォルトのキー | ：
SHIFT併用 | ：

記録開始／記録終了 コマンドで記録したマクロを、外部マクロとして保存します。

SaveMacro

パラメータなし（マクロ内での動作保証はしません）


コマンド－外部マクロ読み込み...

外部マクロ読み込み...

カテゴリ | ：マクロ系
デフォルトのキー | ：
SHIFT併用 | ：

Macroフォルダにある外部マクロをロードして、実行できるようにします。 このコマンドを選択すると、 キーマクロ一覧ダイアログを開いて、 マクロの選択を求めます。

ロードしたマクロを使うには、 再生コマンドを使用します。

LoadMacro

パラメータなし（マクロ内での動作保証はしません）


コマンド－外部マクロ実行...

外部マクロ実行...

カテゴリ | ：マクロ系
デフォルトのキー | ：F2
SHIFT併用 | ：

Macroフォルダにある外部マクロをロードして、実行します。 このコマンドを選択すると、 キーマクロ一覧ダイアログを開いて、 マクロの選択を求めます。

再生コマンドを使用しても、 ここで実行したマクロを使うことはできません。

ExtMacroExecute

パラメータはありません（マクロ内での動作保証はしません）


コマンド－マクロ1～10の実行

マクロ1～10の実行

カテゴリ | ：マクロ系
デフォルトのキー | ：F1～F10
SHIFT併用 | ：

共通設定のマクロのページ で設定された外部マクロ1～10を実行します。

MacroX

パラメータなし（マクロ内での動作保証はしません）


コマンド－マクロ用文字列変換

マクロ用文字列変換

カテゴリ | ：マクロ系
デフォルトのキー | ：
SHIFT併用 | ：

マクロコマンドの記述に使う、 入力文字をダブルコーテーションで囲むための変換コマンドです。 選択された文字列の両端にダブルコーテーションをつけ、 文字列内にダブルコーテーションがあると、 その前にダブルコーテーションを追加します。

EncodeQuote

パラメータはありません。


コマンド－カーソル位置直前のマクロを実行

カーソル位置直前のマクロを実行

カテゴリ | ：マクロ系
デフォルトのキー | ：
SHIFT併用 | ：

カーソルの前位置の単語によって、外部マクロが確定するなら、 その単語を削除してから外部マクロを実行します。 詳しくは、 ヘルプの該当個所を参照してください。

ExecInputMacro

パラメータはありません。


コマンド－その他

その他のコマンド

どのカテゴリにも属さなかったコマンドです。

  • 挿入／上書き切り替え
  • タグジャンプ
  • フリーカーソルモードの切り替え
  • プログラム実行...
  • 現在の日時を入力
  • 現在の日付を入力
  • 現在の時間を入力
  • 整形の一時設定...
  • 観覧モードの切り換え
  • 文字コード変換...
  • 単語登録...
  • 開いているファイルを実行


コマンド－挿入／上書き切り替え

挿入／上書き切り替え

カテゴリ | ：その他
デフォルトのキー | ：Ins
SHIFT併用 | ：

挿入モードと上書きモードを切り換えます。

ToggleInsertMode

パラメータはありません。


コマンド－タグジャンプ

タグジャンプ

カテゴリ | ：その他
デフォルトのキー | ：F10
SHIFT併用 | ：

タグジャンプを行います。 その行の行頭にファイル名があれば、そのファイルを別のK2Editorで開きます。 ファイル名の直後に行番号があれば、その行にジャンプします。

GREP結果に対してタグジャンプを使用します。

TagJump

パラメータはありません。


コマンド－フリーカーソルモードの切り替え

フリーカーソルモードの切り替え

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

フリーカーソルモードをオン・オフします。

ToggleFreeCaret

パラメータはありません。


コマンド－プログラム実行...

プログラム実行...

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

外部プログラムを実行します。

実行すると、プログラム実行ダイアログが現れるので、 ここに必要な設定を行って OK ボタンを押すと、プログラムを実行できます。

コンソールモードにチェックを入れると、 エディタの文字列をコンソールプログラムに渡し、結果を受け取ることができます。 sortやperlスクリプトを実行する際に、便利な機能です。

ProgramExec

ProgramExec(Filename, Opt, Console, StdinOpt, SedoutOpt)

Filename | ： | 実行するプログラム名。フルパスで書く。 マクロ用ファイル名記述基準に従うこと。
Opt | ： | オプション。 マクロ用ファイル名記述基準に従うこと。
Console | ： | コンソールモード。ONにすると、プログラムを実行する際に、 エディタの文字列を標準入力に渡し、 標準出力の結果をエディタに取り込むことができる。 0: オフ 1: オン
StdinOpt | ： | 標準入力に渡す文字列の範囲を指定します。 0: なし 1: 選択範囲を標準入力へ 2: 全文書を標準入力へ
StdoutOpt | ： | プログラム実行の結果、標準出力に出力された文字列をどう扱うかを指定します。 0: なし 1: 標準出力を選択範囲へ（StdinOptが2の時は無効） 2: 標準出力を全文書を置き換える 3: 標準出力を文書の最後に追記 4: 標準出力を新たなエディタで開く

例）
ProgramExec(C:\K2Editor\K2Editor.exe, """C:\Program Files\Readme.txt"" /b")


コマンド－現在の日時を入力

現在の日時を入力

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

現在の日時を、カーソル位置に挿入します。 Windowsの短い形式の日時が入力されます。

InputDateTime

InputDateTime(FmtStr)

FmtStr ： フォーマット文字列。予約語は%で囲む。大文字小文字の区別有り。 文字列の中で%を使用したい場合は、%%のように重ねること。
YYYY | 半角の年 (2000)
WYWY | 全角の年 (２０００)
YY | 半角の年（00）
WY | 全角の年（００）
MM | 半角の月（1)
ZM | 半角の月（01）
WMWM | 全角の月（１)
WZWM | 全角の月（０１）
Month | 英語の月（January）
MONTH | 英語の月（JANUARY）
Mon | 英語の月（Jan）
MON | 英語の月（JAN)
DD | 半角の日（1）
ZD | 半角の日（01）
WDWD | 全角の日（１）
WZWD | 全角の日（０１）
JWEEK | 曜日（土）
Week | 曜日（Saturday）
WEEK | 曜日（SATURDAY）
Wek | 曜日（Sat）
WEK | 曜日（SAT）
HH | 半角の時間（1）
ZH | 半角の時間（01）
WHWH | 全角の時間（１）
WZWH | 全角の時間（０１）
FF | 半角の分（1)
ZF | 半角の分（01）
WFWF | 全角の分（１）
WZWF | 全角の分（０１）
SS | 半角の秒（1）
ZS | 半角の秒（01）
WSWS | 全角の秒（１）
WZWS | 全角の秒（０１）

例）
InputDateTime(%YYYY%/%ZM%/%ZD%) --- 2000/01/01
InputDateTime(%YYYY%年%MM%月%DD%日(%JWEEK%)) --- 2000年1月1日(土)
InputDateTime("%DD%,%Mon%,'%YY%") --- 1,Jan,'00
InputDateTime(%ZH%:%ZF%:%ZS%) --- 01:01:01


コマンド－現在の日付を入力

現在の日付を入力

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

現在の日付をカーソル位置に挿入する。Windowsの短い形式の日付が使用される。

InputDate

パラメータなし


コマンド－現在の時間を入力

現在の時間を入力

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

現在の時間をカーソル位置に挿入する。Windowsの短い形式の時間が使用される。

InputTime

パラメータなし


コマンド－整形の一時設定...

整形の一時設定...

カテゴリ | ：その他
デフォルトのキー | ：Ctrl+Q
SHIFT併用 | ：

整形の各種パラメータを一時的に設定します。 このコマンドを選択すると、設定用のダイアログが表示されます。

ここで行った設定は、保存されません。

QuickSeikeiSet

パラメータなし


コマンド－観覧モードの切り換え

観覧モードの切り換え

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

観覧モードのオン・オフを行います。

ToggleBrowsMode

パラメータはありません。


コマンド－文字コード変換...

文字コード変換...

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

編集ウィンドウ内の文字列を、SJISに変換します。 このコマンドを選択すると、元の文字コードが何かを入力するように求められるので、 その文字コードを入力してください。

K2Editorは、ファイルを読み込むときに文字コードを自動的に認識して読み込みますが、 必ずしも完璧に成功するわけではありません。認識できなかった場合は、 このコマンドで手動で変換してください。

ChangeCharCode

パラメータはありません。


コマンド－単語登録...

単語登録...

カテゴリ | ：その他
デフォルトのキー | ：
SHIFT併用 | ：

IMEの単語登録ダイアログを開きます。選択された文字列を、 そのダイアログ中に入力します。

WordRegister

パラメータはありません。


コマンド－開いているファイルを実行

開いているファイルを実行

カテゴリ | ：その他
デフォルトのキー | ：Ctrl+Space
SHIFT併用 | ：

開いているファイルを実行します。 開いているファイルの拡張子によって、アクションが変わります。 これはエクスプローラでダブルクリックしたときと同じ動作になります。

HTMLファイルの編集などで、このコマンドを使うと、 編集しているファイルがどのように表示されるかを見ることができます。

OpenFileExec

パラメータはありません。


最後に

このプログラムを作るにあたって、以下の方々のお世話になりました。

  • TEditorの作者、本田勝彦さん

    TEditorがなければ、K2Editorはこの世に出ていません。

  • TStringPrinterの作者、本田勝彦さん

    印刷機能にはTStringPrinterを改造して利用しています。

  • JRE32.DLLの作者、山田和夫さん

    正規表現を利用するルーチンは、すべてJRE32.DLLを使用しています。

  • jconvert.pasの作者、EarthWave Soft(IKEDA Takahiro)さん

    文字コード変換ルーチンはこれを使わせてもらっています

また、以下の方々にも多大なご支援をいただきました。

  • K2Soft-MLのメンバーのみなさん

    多くの機能のアイデアとデバッグをしていただきました。

  • K2 Software's Page掲示板で動作報告をしていただいたみなさん
  • メールで動作報告をいただいたみなさん

主にインターネットを通じて、多大な支援と情報を与えていただかないと、 いいソフトは生まれません。これからもよろしくお願いします。

K2Editor copyright(c) 1999,2000 K2
最初　 最後　 戻る　 進む　 目次


K2Editorのヘルプ－目次

  • はじめに

    • 特徴

    • 動作環境

    • 使用条件

    • カンパについて

    • サポートについて

  • インストールとアンインストール

    • インストール

    • アンインストール

    • フォルダ構成

  • 起動方法

    • 起動方法

    • 関連づけ

    • 起動オプション

  • 設定

    • 共通設定

      • 一般設定のページ

      • 行の折り返しのページ

      • マクロのページ

      • キーのページ

      • ツールバーのページ

      • 整形のページ

      • その他のページ

    • ファイルタイプ別の設定

      • ファイルタイプ

      • ファイルタイプの編集

      • 表示のページ

      • 入力と移動のページ

      • ファイルのページ

      • 色のページ

      • キーワードのページ

        • キーワードのプロパティ

      • 文字列とコメントのページ

      • 関連づけのページ

  • キーワード強調表示とカラー化

    • 強調表示とは

    • 12種の文字種とコメント

    • キーワード設定をするには

  • 日本語整形

    • 整形と段落

    • 自動整形

    • 範囲整形

    • インデント整形

    • コメント整形

    • 箇条書き整形

    • スペース補完

    • 行の分割

  • 常駐

    • 常駐の方法

    • 常駐のポップアップメニュー

  • クリッカブルURLなど

    • URL

    • E-Mailアドレス

    • FILE

    • NIFTY-URL

  • マーク

    • 通常マーク

    • 番号付きマーク

    • マーク一覧ダイアログ

  • 検索と置換

    • 検索ダイアログ

    • 置換ダイアログ

  • マクロ

    • キーマクロの使い方

    • キーマクロの保存

    • 外部マクロ実行

    • マクロ割り当て

    • カーソル直前のマクロを実行

    • キーマクロ一覧ダイアログ

    • マクロを記述する

      • SHIFT併用コマンド

      • マクロ用文字列記述基準

      • マクロ用ファイル名記述基準

  • 文字コード変換

    • 文字コードの自動認識

    • 違う文字コードと改行コードで保存するには

  • 画面分割とマルチウィンドウ

    • 画面分割

    • マルチウィンドウ

  • GREP

    • GREPダイアログ

  • ファイル差分

    • ファイル差分機能の使い方

    • diffの実行ダイアログ

  • コマンドヘルプ

    • マクロ専用コマンド

      • 画面描画を一時的に止める

      • 画面描画を再開する

      • メッセージ表示

      • クリップボードに文字列をコピー

      • 文字列挿入

    • ファイル系コマンド

      • 新規作成

      • 開く...

      • 読み直す

      • ファイルを閉じる

      • 上書き保存

      • 名前を付けて保存...

      • カーソル位置への読み込み...

      • 印刷...

      • 保存して終了

      • 終了

      • 全保存終了

      • 全終了

      • 全保存

      • 全保存（更新ファイルのみ）

      • 破棄して終了

      • ファイル名変更...

      • 選択範囲をファイルに保存...

      • ファイルをエクスプローラで開く

      • 保存時の文字コードと改行種類の変更...

    • カーソル移動系コマンド

      • カーソル上

      • カーソル下

      • カーソル右

      • カーソル左

      • 単語右

      • 単語左

      • 行頭に移動

      • 行末に移動

      • 物理行頭に移動

      • 物理行末に移動

      • ファイルの先頭に移動

      • ファイルの最後に移動

      • 次ページ

      • 前ページ

      • 画面の先頭に移動

      • 画面の最後に移動

      • 最後に編集した所に移動

      • 指定行に移動...

      • 現在行のマーク／マーク解除

      • マーク一覧...

      • マーク行の下検索

      • マーク行の上検索

      • マークをすべて解除

      • マーク0～9を設定

      • マーク0～9に移動

      • 下に行スクロール

      • 上に行スクロール

    • 選択・コピー系コマンド

      • すべてを選択

      • コピー

      • 引用付きコピー

      • 貼り付け

      • 切り抜き

      • 単語選択

      • 行の選択

      • 単語をコピー

      • 行をコピー

      • 引用付き貼り付け

      • 開いているファイル名をコピー

      • 箱形選択

    • 削除系コマンド

      • 削除

      • 行削除

      • カーソルより後ろを削除

      • カーソルより前を削除

      • 単語削除

      • バックスペース

    • 挿入系コマンド

      • 改行

      • タブ

      • 空行挿入

    • その他編集系コマンド

      • やり直し

      • やり直しのやり直し

      • 大文字<->小文字の変換

      • 大文字に変換

      • 小文字に変換

      • TAB->空白変換

      • 空白->TAB変換

      • インデント

      • 逆インデント

      • 整形

      • 行の分割

      • センタリング

      • 左寄せ

      • 右寄せ

    • 検索系コマンド

      • 検索...

      • 下候補

      • 上候補

      • 検索開始位置へ戻る

      • 置換...

      • 対応する括弧を探す

      • GREP

      • 検索文字のクリア

      • diffの実行

      • 差分情報の下検索

      • 差分情報の上検索

      • 差分情報のクリア

      • 比較したファイルの該当個所へ移動

    • ウィンドウ系コマンド

      • 縦に並べる

      • 横に並べる

      • 重ねて表示

      • 並べて表示

      • 全部最小化

      • 縦方向に最大化

      • 次のウィンドウ

      • 前のウィンドウ

      • 画面分割

      • ウィンドウのフォーカス移動

      • 分割境界を上へ

      • 分割境界を下へ

      • 別の編集ウィンドウ作成

    • マクロ系コマンド

      • 記録開始／記録終了

      • 再生

      • 記録の保存...

      • 外部マクロ読み込み...

      • 外部マクロ実行...

      • マクロ1～10の実行

      • マクロ用文字列変換

      • カーソル位置直前のマクロを実行

    • その他のコマンド

      • 挿入／上書き切り替え

      • タグジャンプ

      • フリーカーソルモードの切り替え

      • プログラム実行...

      • 現在の日時を入力

      • 現在の日付を入力

      • 現在の時間を入力

      • 整形の一時設定...

      • 観覧モードの切り換え

      • 文字コード変換...

      • 単語登録...

      • 開いているファイルを実行

  • 最後に